Setting WIFI card to promiscuous mode
Results 1 to 10 of 10

Thread: Setting WIFI card to promiscuous mode

  1. #1
    Banned
    Join Date
    Sep 2001
    Posts
    43

    Setting WIFI card to promiscuous mode

    I want to know how to do this in order to capture packets in Ethereal but I cannot find out how do it, anyone know?

  2. #2
    Senior Member
    Join Date
    Dec 2004
    Posts
    320
    In ethereal capture interface dialog there is a 'set to promiscuous mode' button. It is turned on by default. go to capture -> then there is a list of interfaces that you have available. Look for the interface you want to use, then click prepare. You 'set device to promiscuous mode' should be in there.
    The fool doth think he is wise, but the wiseman knows himself to be a fool - Good Ole Bill Shakespeare

  3. #3
    AO Senior Cow-beller
    Moderator
    zencoder's Avatar
    Join Date
    Dec 2004
    Location
    Mountain standard tribe.
    Posts
    1,177
    And just to throw a handful of mud in the water...the device, the driver, and the OS you are using have to support monitor or promiscuous mode.
    "Data is not necessarily information. Information does not necessarily lead to knowledge. And knowledge is not always sufficient to discover truth and breed wisdom." --Spaf
    Anyone who is capable of getting themselves made president should on no account be allowed to do the job. --Douglas Adams (1952-2001)
    "...people find it far easier to forgive others for being wrong than being right." - Albus Percival Wulfric Brian Dumbledore

  4. #4
    Banned
    Join Date
    Sep 2001
    Posts
    43
    I don't think my device supports promiscuous mode as no packets are being captured, anyway to fox this problem? I heard something about using another device driver that supports promiscuous mode.

  5. #5
    Senior Member
    Join Date
    Dec 2004
    Posts
    320
    You might want to double check firewall settings, also. And the WinPCap drivers need to be installed if using ethereal on windows (although I believe it is installed when Ethereal is installed).
    The fool doth think he is wise, but the wiseman knows himself to be a fool - Good Ole Bill Shakespeare

  6. #6
    Member
    Join Date
    Oct 2002
    Posts
    81
    If your using windows...good luck. I haven't been able to do anything interesting with windows and you have to buy a specific card to get it to work. Google up Airopeek and thats pretty much it when it comes to windows wifi sniffing. It's a pricey product, but Airsnort works with it, so I'm not sure if Ethereal can be rigged to work with it.

    If your using Linux, your options are alot more open. I'd recommend looking for a Dlink DWL 122, as I've had good luck using it. It's a USB wifi adapter based on the prism2 chipset and it's around $10-15 used. I'm almost positive that if you buy one, it will work using WLAN tools. Good thing about the DWL 122 is that Dlink didn't change chipsets with it. You have to be careful with Wifi cards, just because it's the same model number, doesn't mean it has the same chipset.

    With the card above, it's a B only card. It won't do G. I haven't followed up with wifi sniffing but I think it's only possible on B at this point. Things may have changed in the past 6 months to a year.

    The card above uses WLAN tools and is fairly easy to set up, configure and use. Don't be scared of the command line.

    A great Linux LiveCD is Auditor, which is a nice collection of security tools. It supports wifi card for this purpose. I say burn some bandwidth and just try it out. Your card may work right away.

    Anyhow, with the proper card, and the right linux driver you can get the card to go promiscuos. Then you can capture with Ethereal or whatever your heart desires.

  7. #7
    Banned
    Join Date
    Sep 2001
    Posts
    43
    I'd love to use Linux and do have a few distro's including Auditor but, I just cannot get my wireless card installed even when using ndiswrapper.

    I'm going to try the Dlink DWL 122 with Linux, I guess using the command line puts me off Linux quite a lot, seems quite confussing but will get the DWL-122 and play around.

  8. #8
    Member
    Join Date
    Oct 2002
    Posts
    81
    What kind of card is it? With linux are you just using a livecd or do you have a full install to play around with?

    For Windows, check out the Airopeek site. They have a pdf of all compatible cards. You won't be able to go promiscuous without it. Windows doesn't allow setting the cards to promiscuous if I remember correctly.

    I'm sad to say your only option may be to get a new card. I screwed around with a few different cards before I could get it to work, including one with Linux support. That's with just getting it to load, not even setting it to promiscuous.

  9. #9
    Member
    Join Date
    Oct 2002
    Posts
    81
    If you don't want to mess around with the command line, just use Auditor. My copy picked it up right after I plugged it in and Kismet was up and running within about 1 minute after. Just wait to plug in the DWL until after Auditor finishes booting up.

    PM me if you need any help with it. I have to warn you though, I'm not exactly Mr. antionline, so the response may take a few days.

  10. #10
    Banned
    Join Date
    Sep 2001
    Posts
    43
    Thanks killerbee, I probably won't get the new device until after the new year!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides