PHP & Apache help
Results 1 to 7 of 7

Thread: PHP & Apache help

  1. #1
    Banned
    Join Date
    Sep 2001
    Posts
    43

    PHP & Apache help

    I've added a PHP upload script to my server but as I am using Windows I cannot CHMOD the uploads directory to 777 so I cannot upload stuff, what can I do?


    I want to be able to show the index of one of my directrys on my server but if I do www.mywebs/blah I get an error 403 Access forbidden, how do I fix this?

  2. #2
    Are you uploading the files with a FTP client?
    is so then click on the folder or file, and choose properties/CHMOD
    And just change the permissions that way.

    cheers
    front2back

  3. #3
    Banned
    Join Date
    Sep 2001
    Posts
    43
    Not using anf FTP client, just droping the files into my servers root folder. Tried an FTP client and when I try to CHMOD I get an error saying "500 Syntax error, command unrecognized". I assumed I got this error as Windows doesn't allow the use of the CHMOD command.

  4. #4
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    Use the windows file security, make sure the useraccount the webservers runs on has atleast read access.. (For IIS that's usually IUSR_MYMACHINE).. chmod 777 means writeable by everyone..

    A 403 Error is usually because there's no default page (like index.htm or default.asp) and you've turned off directory browsing..
    Oliver's Law:
    Experience is something you don't get until just after you need it.

  5. #5
    Banned
    Join Date
    Sep 2001
    Posts
    43
    Which file do I need to edit in order to enable directory browsing?

  6. #6
    Senior Member Raion's Avatar
    Join Date
    Dec 2003
    Location
    New York, New York
    Posts
    1,299
    I think you need to give us more information and be a little more clear about your question.

    Here's what I'm assumming & understand, correct me if I am wrong, you are trying to get run a webserver locally with apache & php, however you cannot access the index because you get a 403 error?

    If that in fact IS your problem, here are my suggestions:
    1.) Are you sure you ran Apache prior to trying to connect
    2.) Did you try to connect to your local IP (127.0.0.1)
    3.) Are you sure you have an index file in the directory specified in the configuration file of Apache
    4.) If all above fail, revise you're configuration file (I haven't used Apache in ages so I forgot the name of this file and the directory it is located in)

    EDIT: The config file is called httpd.conf you can edit it in notepad.
    WARNING: THIS SIGNATURE IS SHAREWARE PLEASE REGISTER THIS SIGNATURE BY SENDING ME MONEY TO SEE THE COMPLETE SIGNATURE!

  7. #7
    Shrekkie Reloaded Raiden's Avatar
    Join Date
    Oct 2005
    Posts
    1,115
    Hey,

    The 403 shows the apache is running, but probably is the indexing off.
    Try to set apache to show you the dirlistings.

    You can do that by inserting the following in your httpd.conf. I know in linux that file resides in /etc, but i have no idea on windows.

    Code:
     <Directory /path/to/directory>
       Options +Indexes
    </Directory>
    Hope that helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •