from Secunia:

Aliaksandr Hartsuyeu has discovered a vulnerability in My Little Forum, My Little Guestbook, and My Little Weblog, which can be exploited by malicious people to conduct script insertion attacks.

Input passed to the "link" bbcode tag when posting a message isn't properly verified, before being used. This can be exploited to inject arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site when a malicious link with the "JavaScript" URI handler is followed from a malicious message.


The vulnerability has been confirmed in the following products:
* My Little Forum 1.5
* My Little Guestbook (latest version)
* My Little Weblog (latest version)

Other versions may also be affected.

Edit the source code to ensure that input is properly verified.
AO's not running 'My little Forum' is it

here is the link: