Results 1 to 3 of 3

Thread: Hardware RAID 5 recovery

  1. #1
    Junior Member
    Join Date
    Feb 2006

    Unhappy Hardware RAID 5 recovery

    Hi, one of my server's just crashed and it had a RAID 5 array on it. I can see the physical devices in windows and linux, but I can't see the partition's it houses. It should show 3 partitions, from 4 drives.

    I can see the partitions and browse it only in the Windows Recovery Console. It seems to work fine in here. But no where else. I would like to move a large amount of the files from here to somewhere else, but copy in Recovery Console only does one at a time.

    I have tried using Knoppix 4.0.2 (latest) and mdadm to mount the partition but to no avail, although the guides I was using were using were far less than complete. There is no /proc/mdstat which most guides refer too. I think it could be because of the hardware.

    I had to resort to copy file by file from one drive to another and recreating the directory structure to get some critical things up and running. But the rest is killing me.

    The hardware RAID is Adaptec AAA-133U2 part of the Adaptec Array1000 Family. We have a non RAID SCSI adapter we can connect it to, if software can emulate the raid. When we connected it to this it detected all the drives, but could not mount the partitions. It does not appear to be a RAID card problem since we swapped it out with an exactly identical card, same model firmware, and bought at the same time.

    The software manager for the RAID adapter says it can not detect/communicate with the card, but it has to be possible since we can in Windows Recovery Console.

    I am just about to try WinPE and Ultimate Boot CD, in the hopes os salvaging this.

    Any ideas? Anyone able to type a consice walk through on how to use linux to mount a raid, without it having been created in Linux (which seems to be the problem).

  2. #2
    Senior Member Maestr0's Avatar
    Join Date
    May 2003
    Hardware RAID arrays are invisble to the OS, mdadm and raidtools in Linux are software RAID arrays. The Adaptec controller is used to create the drive configuration and presents the configured arrays to the OS. A RAID 5 can survive a single drive failure and still rebuild the array. You need to enter the Adaptec controllers ROM at boot time when it flashses its message, you should be able to examine your physical drives and determine which one has failed. You need to then replace the failed drive, initialize it, and then bring it into the array and rebuild the array, then you should be back in business. If you change controllers you will probably lose everything because different controllers tag the drives differently and the array configuration will be lost, I have succesfully done it, but you must use the exact same controller card and even then its dicey.

    \"If computers are to become smart enough to design their own successors, initiating a process that will lead to God-like omniscience after a number of ever swifter passages from one generation of computers to the next, someone is going to have to write the software that gets the process going, and humans have given absolutely no evidence of being able to write such software.\" -Jaron Lanier

  3. #3
    Junior Member
    Join Date
    Feb 2006
    I have tried going into the controllers BIOS. All drives seem to be fine. I know that it's Hardware and the others are Software I was just hoping it could read them.

    In the Recovery Console we did a chkdsk of all the drives contents and it had no problems. The drives i'm almost certian are fine. In the Recovery Console we can view it using either controller card, since they are the same manufacturer, model, firmware.

    The configuration utility though says there is no RAID device.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts