Linux Distro Nightmares
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Linux Distro Nightmares

  1. #1
    Join Date
    Jan 2006

    Linux Distro Nightmares

    Hello guys, am back and HAPPY EASTER to AO!

    Ok, I'm trying to find a stable and fast Linux release that I can install on Pentium-1 machines (166Mhz-233Mhz roughly). It doesn't need to be anything fancy, I just need to be able to install a webserver, terminal program, and maybe browse the net / wordprocess.

    So far I've not had a great deal of luck, I have tried :

    Redhat 9 - Way too bloated, too slow.
    Damn Small Linux, HDD install - Too slow again, sluggish response
    Ubuntu - Lol, too slow again
    Debian - Couldn't get it to detect the NIC for network install, so not sure.
    Slackware - Just downloaded, about to try.

    I was wondering, before I waste even more time, if Slackware will be any good on such slow machines. It says it can run on a 486, but how well?

    Also, supposing I can get Debian onto one of the machines, how well would that run? I'm having difficulty finding any guide to system requirements for Linux distros.

    Would getting hold of an older distro of Slackware or something similar be a better idea?


  2. #2
    I was wondering, before I waste even more time, if Slackware will be any good on such slow machines. It says it can run on a 486, but how well?
    Slackware will work really good on a p166, providing you have enough ram. 64mB would be enough, if you intend to use a graphical desktop such as kde 128mB would be better.

    A good resource for distros is:Distrowatch

  3. #3

    Debian would work on the above mentioned machine, it won't be the quickest but it will be able to run on it..

    I've gotten it to run on shitty box's before just for ****'s and giggles, so i doubt you should have any dramas running it.


  4. #4
    You probably forgot to install the bootloader (usually lilo with slackware) or you didn't install it in the mbr like it should be when you only have one o/s installed.

    Give more details, and we'll try to help you. The solution is not to run after a new distro everytime you have one problem, but to try installing one properly.

    Give us the number of hard-drives, the way you partitioned it or them, tell us if you want a dual boot setup or if only linux will be installed on that computer. Give some details about the computer, it's not because it's linux that we don't need to know about the hardware where it will be installed.

  5. #5
    Junior Member
    Join Date
    Mar 2006
    good luck, i got an old box laying around (66 mhz 40 mb ram)

    so if you find something that runs good on such low spec's id find the information useful

  6. #6
    Join Date
    Jan 2006
    Thanks, yeah I do need to stick at it and get it working instead of just going through endless distros!

    I tried installing Slackware again last night, on a quicker install without so many packages (the packages are overwhelming!)

    If I remember correctly, the first thing I did was partition in cfdisk a main partition (2GB, Linux FS, Boot flag set) this was at the beginning of the drive. Then I used the rest of the space on that drive (about 100MB) as the swap, and set the filesystem to 'Linux swap'.

    I ran through the installation, and right at the end I chose the default kernel from the CD that I had used throughout the install process. I cannot remember exactly what I did with the bootloader, although the first time I installed I chose the 'safe option' which was to skip. That's all I can remember, I was rushing through it which probably isn't the best thing to do - I'll try it again tonight and write everything down (real newbie style). As for the system, I'm not dual booting, it's a fresh start, Linux only. Spec of this particular one is :

    IBM 'Aptiva'
    Single HDD (About 2GB)
    128MB RAM
    P1 233

  7. #7
    Senior Member
    Join Date
    Feb 2002
    You might want to do some more research on this, so don't take my word for it, but if you're using KDE or Gnome with 128 megs RAM, your system probably will run slower. It might not be the distros but your lack of memory. The guis tend to be resource intensive. Try a lighter desktop environment such as Xfce. ( If you only have 128 megs your system probably will be swapping a lot which will make it run slower.
    For the wages of sin is death, but the free gift of God is eternal life in Christ Jesus our Lord.
    (Romans 6:23, WEB)

  8. #8
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    To add to what preacherman481 has said, your 128Mb of RAM is a little on the small side for a modern distro with all the GUI.

    Added to that, your swap partition is small at 100Mb. I would try for 256.

    Lastly, that is a very old drive, and will be pretty slow anyway.

    I took an old Digital Venturis PI/133 and stuck 320Mb of RAM, a 32Mb videocard and a 7200Rpm HDD in it. It runs as fast as a contemporary PII/233

  9. #9
    Join Date
    Jan 2006
    Argh! Maybe Linux doesn't like IBM? I'll have to look into Vector sometime as well.

    Ok, I've just re-installed Slackware again, and I'm getting the same old 'missing operating system' after re-booting. This time I've written everything down, so I'll copy it here before I lose this piece of paper :

    1. Created primary partition, 2000MB, @ end of disk = /hda1 (Type 83 - Linux)
    2. Created logical 110(ish)MB partition at start of disk = /hda5 (Type 82 - Linux Swap)
    3. Set boot flag on /hda1
    4. Write partition data, check and exit. Start 'Setup' for Slackware
    5. Remap keyboard, addswap - /hda5
    6. Formatting swap...ok.
    7. select /hda1 for Linux install partition
    8. selected slow format, using ext2 FS
    9. formatting.....ok.
    10. select install from dvd/cd, scan for disc.
    11. Choosing packages - removed 'development' and 'source code' packages only
    12. Set it installing packages, after going through the menu mode (made no changes).
    13. ....Insert disc 2, removed accessibility from KDE, set it installing again
    14. Set root password? -selected 'No'.
    15. 'Exit setup and reboot by hitting ctrl-alt-del'
    16. Exited setup, hit ctrl-alt-del
    17. 'Missing Operating System'!

    So I suppose I need to install LILO, interestingly this time I did not get an option to do anything with the bootloader. I haven't got a clue how to install it manually, anyone? In the meantime I'll google for info and probably wreck the whole installation yet again

  10. #10
    At the end of the installation, you should have gone back to the main menu and select to install the boot loader. You will have the same problem with Vector linux, as you have to select to install the boot loader manually, it's not that Slackware isn't compatible with your IBM computer. You should probably try with Mandriva or Ubuntu, at least with those the boot loader is installed automatically for you.

    The Older Vers of Red Hat was the same way, they gave you options of boot loaders, but if you missed it then well you know.....

    SuSe installs it automatically too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts