Results 1 to 3 of 3

Thread: subversion help

  1. #1
    Custom User
    Join Date
    Oct 2001

    subversion help

    I've recently installed apache 2 and subversion and seem to be having some trouble getting them to integrate. I'm fairly certain that subversion is working ok (seem to be able to import and checkout although I haven't tested it extensively). First I'll give you a list of my system details:

    Win XP
    Apache 2.0.55
    Subversion 1.3.0

    The problem I'm having is that every time I attempt to access my subversion repository I keep getting a 403 Forbidden error. I've tried a whole load of different setups, have installed and uninstalled both Apache and Subversion numerous times as well as allowing the Subversion installer to automatically configure Apache and doing the configuration myself manually.

    I'm guessing that the problem must be something to do with file access permissions, but I don't really understand why this is a problem/how to fix it since I'm running Win XP (my knowledge on XP permissions and access rights is a bit primitive).

    Here's my Location tag from httpd.conf:

    <Location /svn>
      DAV svn
      SVNParentPath C:/svnrepos
    #  AuthzSVNAccessFile etc/svn-access-perms
      SVNPathAuthz off
      AuthType Basic
      AuthName "Subversion repository"
      AuthUserFile etc/svn-auth-file
      Require valid-user
    Note that the problem isn't at the HTTP authorization stage since it seems to accept my username and password fine.

    [edit]After writing all that I thought of changing SVNParentPath to SVNPath and it worked fine. I'm still going to post this because I don't understand why this should matter and I'd like any opinions on the matter - also it might help someone else.[/edit]



  2. #2
    Join Date
    Jan 2006
    Hi Gothic,

    I think if it were the firewall then you would get a 'Page Not Found' error or similar.

    The fact that you are getting an Apache Server error message indicates that the firewall is letting traffic through port 80.

    I would probably be looking at the fact that you do not have an index page in your root directory of the website space.

    If you are not using VirtualHosts then make sure there is an index.html page in your ../Apache2/htdocs/ folder.

    If you have configured any VirtualHosts then these override the /htdocs/ folder which will be ignored, so you therefore need to ensure that there is at least an index.html file in your root folder as specified in your VirtualHosts container block.

    If you are still having trouble, let me see the httpd.conf file and I'll take a look.

    But that is initally what it sounds like it could be.

  3. #3
    Custom User
    Join Date
    Oct 2001
    Thanks for the input although I had actually managed to get it working.

    If you take a look at my post in between [edit] and [/edit] I explained the workaround I used. The only problem with it is that I can't understand why it would cause a problem like that. Ah well.

    Thanks anyway,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts