RAID 0 Recovery? - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: RAID 0 Recovery?

  1. #11
    Senior Member
    Join Date
    Oct 2003
    Posts
    268
    No luck with chkdsk or fixmbr in recovery console. Chkdsk wouldn't even run.

    ZT3000 - will the RAID Reconstructor Software trial work or will i need to buy it?

    Also i've attach a pic of what i'm seeing. The Raid still shows up in the mobo's utility.

  2. #12
    Senior Member
    Join Date
    Oct 2003
    Posts
    268
    but in this next pic you'll see that windows still shows it as unallocated...

    ZT3000 - so i don't think RAID reconstructor is going to work. It wants two seperate drives but the raid is still seen as one.

    *note* In the picture, I've installed a second harddrive to boot to. That is the disk 0 with 114GB.
    The drive in question is the Disk 1

  3. #13
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,191
    Hi,

    I finally got some feedback. No one has tried a RAID 0 recovery with 64 bit Windows. This product was suggested:

    http://www.active-undelete.com/faq-raids-types.htm

    From what I was told, it would be an idea to Google for "RAID recovery" download some of the demos and run them. They should tell you what the particular tool can recover, so if you find one that will do the job, buy that software.

    There are quite a few companies that offer RAID recovery services but they are very expensive, like all data recovery services
    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  4. #14
    Senior Member
    Join Date
    Mar 2005
    Posts
    400
    Aden,

    Sorry, I didn't get back to you earlier. I had a late night working and a somewhat busy morning thus far.

    I don't know that the RAID reconstructor software WON'T work on RAID0 that is recognized as one drive. I do know it will work if you delete the array connection (which does not delete the data contained on each drive if it's a RAID1, not exactly sure about RAID0).

    With that said, I think your problem concerns a different situation. Bear with me.

    First off, Running chkdsk and Fixmbr was a wrong answer from your school.
    I know they had good intentions but ......
    NEVER alter a RAID array without deciding what the problem is and how to correct it. Attempting crapshots in the dark cause problems, they don't call it 'crap'shots for nothing.

    Secondly, I hope you ONLY used the WinXP 64bit CD when using recovery console and any other command line software. Do NOT use the WinXP 32bit CD.

    At this point I cannot tell what the source of the problem WAS, since you tried too many things but soon enough I can tell you what the problem suggests.

    Let's assume the RAID0 array is functional according to the RAID firmware, as evidenced by your screenshots. So we assume you have a good array.
    I need you to check the logical drive info of the array by going into the RAID CMOS setup. We need to check if the first drive (master) is still the boot drive (in other words, does it still have a bootup marker/identifier), which should be listed on the right hand side of screen as "boot" or "bootable".

    You've run FixMBR which seemed to do nothing but may have adversely affected the partition table, as it rewrites the partition table and a small amount of boot sector code.

    So at this point, after you have checked the status above, I want you to attempt a bootup of the array and tell me where it's hanging up and what messages are showing if any. If it hangs up without error messages, I need to know how many seconds after the RAID CMOS message (in white letters on black background) DISAPPEARS that it hangs up at. That way I can estimate what it's doing when hanging up.

    Thanks.

    [Edit: Don't worry about the 64bit stuff. As far as I know, the file system is still NTFS 5.0/5.1 for 64bit systems which is what XP and Win2003 lay down. NTFS is a 64bit file system already and it's overall size is limited to 2TB by Windows XP 32bit. As long as we don't mess with files we should be okay.]
    ZT3000
    Beta tester of "0"s and "1"s"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •