i ran into this and wanted to share. orginally going to be a question, but i found out what caused it and now wanted to let others know. we are using vmware workstation 4, however when we booted up today, we noticed 1) that vmware could not find our license files and 2) our vmware configurations seemed to be missing. then we saw that our vmware4 had somehow became vmware5!

unfortunately, i did a knee-jerk reaction and just acquired a temp license and setup a new vm to see if that still worked - it did, but i should have just called support first instead of second. i found - or actually remembered that it can do that since 4 - out that vmware can be configured for automatic updates. you go to Edit -> Preferences -> Workspace , and then adjust the "Check for Software Updates " setting to your liking.

however, that did still not resolve the issue of the automatic upgrade to workstation5, the supposed removal of our licenses and configurations! their support told us - and this is verbatim "Well, it's not supposed to do that!" solution? they told us to remove 5, reinstall our version, put back in our license code, setup our vms' again.

we decided to put the brakes on this and start looking around the machine first. lo and behold, we found the license files and even the vms'; workstation5 was looking in a different directory. however, we wanted workstation4, so we reinstalled 4 - repointed the license and vm directories and *bam* we were back up. and in only two hours time.

so just fyi and if you have any vmware wisdom, i would love to read it!