It was just this morning that I opened my THUNDERBIRD and it asked my gmail password as Usual. I entered it and after 2 seconds I was told that I had entered a wrong password!! I ried it twice and then with othe email clients like outlook, opera eudora etc. Every other email client said the same thing that my password was wrong!!! I ckecked settings...they were all correct!!

I decided to log into the gmail account from the Browser ( firefox and to my surprise I was told that my password was wrong!! I was afraid of my account being hacked!! I use a storng password ... even then thinking that it might have been reset by someone using an Input validation attack, I opted for the "cannot access my account" link and gmail sent me my reset link on my alternate address! Now I tried logging in and still got the same problem!!

I really didnt believ my eyes!! How can it say that the password was wrong! I had reste it just 12 seconds ago!! ANyway in frustration I again tried resetting and after resetting this time, I luckily got access to my mails in my browser.

But my email clients are still complaining that I have entered a wrong password!! Both thunderbird and opera! I tried logging in to the gmail on HTTP ( browser) twice and I succeeded both times ( after resetting my password twice). But I am still unable to access my mails in the mail clients!!

Please do not advice me the follwing things....I have done that many times with utmost care and attention:

1. Entering the password correctly.
2. Checking POP and SMTP settings with correct authentication and port numbers.
3. Clearnign cache of browser.
4. Using all the measures tht can be taken in a normal desktop environment: antivirus, antispyware and firewall with strict rules.

Also I am not a part of a network but am connected to my ISP directly through my mobile. How is all possible??

Also I must say that this problem is occuring for only 1 account. I have 3 gmail accounts for different purposes and 2 of them are working fine and as-usual. What has gone wrong with my first account??

I have reported the problem to the google help team. But how can this happen?? What would have been wrong on either sides.

I just need comments on this topic. (Suggestions for solving this problem are most welcome).