[Suse 10.1]Problems loading reiserfs, pointing on wrong harddisk!
Results 1 to 8 of 8

Thread: [Suse 10.1]Problems loading reiserfs, pointing on wrong harddisk!

  1. #1
    Junior Member
    Join Date
    Jul 2003
    Posts
    8

    [Suse 10.1]Problems loading reiserfs, pointing on wrong harddisk!

    Hi everyone on Antionline,
    I know this maybe isnt in topic for this forum but i know many of you have great
    expierence and knowledge.

    Information about my system:
    Harddisk1 160gb: one partion WinXp 70gb, installed suse 10.1 on the rest with standard partions.
    Dvd/Cd-rom: Nec

    Everything worked nice until i plugged in my second 160gb hd.
    But now i can't load my Suse partions!? The computer thinks that my linux partions is on hdb
    but it should be hda.
    The message i get when i trying to load it is:

    trying to load reiserfs...
    /dev/hdb5 -no response
    Waiting for device /dev/hdb6... -no response
    $


    I have tried to unplugg my hd again but there is no effect.

    Does anybody have an answere to my problem?
    How can i change the settings, so the computer can load the right partions?

    //Lazyfish (Totally newbie on Linux)

  2. #2
    Junior Member
    Join Date
    Sep 2005
    Posts
    17
    you probably would want to reinstall grub and check if that works. just boot into rescue mode using your media and use grub-install /dev/hdb.

  3. #3
    AO BOFH: Luser Abuser BModeratorFH gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177
    You plugged in another Hd? Like USB? Or an Internal HD?

    Now I could walk you through 200 steps to fix this, but if you just installed SUSE and don't have a lot of data on that yet, you can do one EASY step, and reinstall it, setting the partitions up.

    On the machine I'm typing on this is my set up:

    I have one 80 GB HD the machine came with, and one 160 GB HD I installed, and then an 80 GB External USB HD.

    When I set it up, I installed XP on the first HD and gave it the whole thing. When I installed SUSE 10.1 I gave it the second HD.

    The install went without hassle and it did most of it for me. I checked the partitions to make sure it was what I wanted, and when everything was done I plugged in the USB drive and SUSE popped up letting me know it found an 81 GB media.

    I opened it with the file manager and that was it.
    Kill the lights, let the candles burn behind the pumpkins’ mischievous grins, and let the skeletons dance. For one thing is certain, The Misfits have returned and once again everyday is Halloween.The Misfits FreeBSD
    Cannibal Holocaust
    SuSE Linux
    Slackware Linux

  4. #4
    Junior Member
    Join Date
    Jul 2003
    Posts
    8
    hi,
    yet i haven't got sensitiv information on that partion. A reinstall may solve my problem.
    But why dont try to learn how to fix it instead?

    2 internal hds 160gb.
    Problem begun when i installed my second drive.

    Problem again:
    Startup is pointing on wrong drive. It should be /dev/hda not /dev/hdb.

    Grub? Is it really grub who decides what settings suse will use?
    Were is the file for change these settings?

    After couple of minutes thinking...
    Gore* maybe i should go your way. Use one drive only for winxp and the other one for Suse.
    In that case, were should i put grub? hda or hdb.
    And can i have both disks in the computer under installation?

    My WinXp partion is more sensitiv... Can i delete suse partions from this drive without destroy
    data from winXp partion.

    sorry for bad writting.. Hope you understand

  5. #5
    AO BOFH: Luser Abuser BModeratorFH gore's Avatar
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    7,177
    I speak / miss spell in 7 languages, I understand. Grub will install itself on the first HD, which is where it needs to be to boot OSs. When you install SUSE, just tell it to use the seciond HD and auto partition.

    It'll set everything up and you won't have to do anything. You can learn how to fix it after you have the installation down. Makes things easier.
    Kill the lights, let the candles burn behind the pumpkins’ mischievous grins, and let the skeletons dance. For one thing is certain, The Misfits have returned and once again everyday is Halloween.The Misfits FreeBSD
    Cannibal Holocaust
    SuSE Linux
    Slackware Linux

  6. #6
    The Prancing Pirate
    Join Date
    Jul 2004
    Posts
    548
    Where exactly does this happen? Right after you choose the installation on GRUB?

    If so, shove in a live CD like Knoppix, reboot, load it up, and then mount your / partition (let's say it's /dev/hda1) to /mnt/linuxroot.
    Code:
    $ su
    Password:
    # mkdir /mnt/linuxroot
    # mount /dev/hda1 /mnt/linuxroot
    # kwrite /mnt/linuxroot/boot/grub/menu.lst
    You could post the output of that, or, alternatively, just change all the references of "hdb" to "hda". You haven't installed anything on hdb yet, have you?

    Do the above if you want to recover it. If not, your best choice is to reinstall... Back up the stuff on the Windows partition and erase it. Then, resize the reiserfs partition (/ ?) on hda to take up all the space. Once that's done, install Windows on hdb. In doing that, M$ will put their own mumbajumba on the MBR, so you'll have to reinstall GRUB.

    If you need any help doing any of this, just ask.

    Cheers,

    -jk
    TAZForum <---- click

  7. #7
    Blast From the Past
    Join Date
    Jan 2003
    Posts
    729
    i had a similar problem using grub... i installed a second hdd.. one ide one sata... and grub got all confused and would point to the wrong drive... 60 collective hours of man pages and 1 case of dr. pepper later i said Eff this and whipped out lilo.

    i wouldnt mind seeing a solution from someone to this problem if one comes along
    work it harder, make it better, do it faster, makes us stronger

  8. #8
    Junior Member
    Join Date
    Jul 2003
    Posts
    8
    hexadecimal&gt;&gt; I understand what you mean.

    To stop anyone for posting a solution and not to hurt hexadecimal i just want to say that my problem is solved.

    The solution
    my solution was a extreme makeover. Reinstalled everything. Using my second computer as a SUSE box instead.


    And i want to thank everyone for a fast reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides