Soft link didn't work in MRTG.
Results 1 to 5 of 5

Thread: Soft link didn't work in MRTG.

  1. #1
    Junior Member
    Join Date
    Sep 2006
    Posts
    11

    Soft link didn't work in MRTG.

    HI all
    I create a mrtg for one cisco switch (24 port). When I have to do the same thing again and agian in the same computer but in different locatation, then I think that I would create a softlink of index file and will made visible through every part of this computer. But when I tried to do so. it gives following error.

    ERROR: Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


    But when I do the same thing using Hard link , it would work. But I have heard that there is more vulnerability in creating hardlink and give the link to the customer. so plz can anyone suggest me what to do in this situation . ( I will not prefer mrtg twice or thrice in the same computer for same cisco switch).

    Thanx in advance.

    Umesh

  2. #2
    Senior Member
    Join Date
    Mar 2004
    Posts
    119
    I believe that I am missing something in the translation. Perhaps you could give us more information on what you are trying to accomplish.

  3. #3
    Junior Member
    Join Date
    Sep 2006
    Posts
    11
    ok in short , what I am trying to say you all is how can I access the single mrtg page through multipe directories using soft link..

  4. #4
    Senior Member
    Join Date
    Feb 2003
    Location
    Memphis, TN
    Posts
    3,747
    you mean sym link?



    whatever directories you want to be able to access the index file, you can just symlink to it.


    Use the command:

    ln -s /path/to/file /path/to/directory that you want the link in.

    For example if you have a index file in /home/www/index.html and you want it linked to /home/user/bw

    the command woudl be

    ln -s /home/www/index.html /home/user/bw


    that should work for you.


    Again this presumes your using linux, which I assume you are.
    =

  5. #5
    Senior Member Maestr0's Avatar
    Join Date
    May 2003
    Posts
    604
    Apache will not follow symlinks (softlinks) with out a 'FollowSymlink' option in the <Directory /mydir> directive where the symlink resides, in the config file for the site.

    eg.
    <Directory /www>
    Options FollowSymLinks
    </Directory>


    -Maestr0
    \"If computers are to become smart enough to design their own successors, initiating a process that will lead to God-like omniscience after a number of ever swifter passages from one generation of computers to the next, someone is going to have to write the software that gets the process going, and humans have given absolutely no evidence of being able to write such software.\" -Jaron Lanier

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides