Update ASAP.. This one corrects 4 CRITICAL vulnerabilities (vulnerability can be used to run attacker code and install software, requiring no user interaction beyond normal browsin)

and 2 moderate vulnerabilities (Vulnerabilities that would otherwise be High or Critical except they only work in uncommon non-default configurations or require the user to perform complicated and/or unlikely steps.)

Happy Updating.