Networking Windows > Kubuntu
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Networking Windows > Kubuntu

  1. #1
    Agony Aunty-Online Moira's Avatar
    Join Date
    Jun 2003
    Posts
    1,063

    Thumbs down Networking Windows > Kubuntu

    This isn't exactly a security problem, but it does touch on it. I've installed kubuntu onto an old laptop and it sees the Windows network straight away, but I can't figure out how to do it in the other direction. I had Suse installed as a dual boot option some time ago, and I remember it being a right royal pain installing and configuring Samba. I had hoped that Kubuntu might have made some improvements over Suse 9, but it seems not.

    While I don't have to install Samba (it's already there), this network isn't going to "just work". I saved a samba config file from Suse and thought I might be able to just copy it across - but it seems I don't have the right permissions. Linux annoys me like this - it resembles the way Vista's gone, ie all of a sudden you can't do what you want with your own computer. I'm the only user for heaven's sake, why can't I alter a file? Unlike Suse, I didn't notice a "root" option during the install and have no idea how to either go about replacing the default Samba file with my saved one, or see the kubuntu files in my network places here.

    Can anyone help?
    77 111 105 114 97

    My PGP signature

  2. #2
    Junior Member
    Join Date
    Aug 2002
    Posts
    1
    Can you use the Command Line to copy it over while using sudo? I know root is disabled by default on Ubuntu but you can still use sudo with your own password.

  3. #3
    Agony Aunty-Online Moira's Avatar
    Join Date
    Jun 2003
    Posts
    1,063
    I could try .... what's the command for a) renaming the original samba file (in case this one isn't suitable at all, so I can keep it) and b) for copying my samba file from this pc? Sorry to appear so ignorant but there isn't much point in me trying until I can master this basic stuff - I'm just not used to command line prompts at all.
    77 111 105 114 97

    My PGP signature

  4. #4
    Gonzo District BOFH westin's Avatar
    Join Date
    Jan 2006
    Location
    SW MO
    Posts
    1,188
    To rename the original samba file, I would use the 'mv' command. for example:

    mv samba.conf samba.conf.bak [it might be smb.conf I cannot remember for sure]
    make sure that you are root by typing
    sudo -H -i
    and then enter your password.

    as far as copying the file from one pc to another, I would suggest a Thumbdrive, [K]Ubuntu seems pretty good about recognizing USB storage devices.

    Hope this helps...

    westin
    Last edited by westin; November 27th, 2006 at 10:27 PM.
    \"Those of us that had been up all night were in no mood for coffee and donuts, we wanted strong drink.\"

    -HST

  5. #5
    Agony Aunty-Online Moira's Avatar
    Join Date
    Jun 2003
    Posts
    1,063
    Surely my network will copy the file? Don't forget I can view all windows files and folders from kubuntu. I just don't have the damned necessary permissions to replace my own samba file on my own computer ! When I try to paste the file into place, it won't allow it. Would a command line command not be able to access a networked share and copy it? If I stick it on a usb drive I'm going to have the same problem with permissions and no way to get round it.
    77 111 105 114 97

    My PGP signature

  6. #6
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    Ubuntu (and derivatives, I assume) disables the root account by default. That means that you have to use sudo to do root tasks. Westin pretty much had it covered, but I should mention that when sudo asks you for a password, it is your password and NOT the root password. There isn't a way to set the root password and have it be useful anyway.

    Cheers,
    cgkanchi

    EDIT: Found the Ubuntu documentation page for sudo. https://help.ubuntu.com/community/RootSudo
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  7. #7
    Gonzo District BOFH westin's Avatar
    Join Date
    Jan 2006
    Location
    SW MO
    Posts
    1,188
    did you try sudo -H -i ? that should give you root permissions... I am running Ubuntu right not... and it let me rename my smb.conf file and create a new one. you might try pasting the file to your desktop.. from the network, [you should have sufficient permissions to do that without being root] and using the command line to move it into place, with root permissions.
    cp /home/username/Desktop/smb.conf /etc/samba/smb.conf
    [after you create a backup of your samba config file of course ] sorry if I am not much help... but I try

    /* edit: Check out this link if all else fails http://www.ubuntuforums.org/showthread.php?t=202605 it is a howto for ubuntu/windows networking for samba */
    Last edited by westin; November 27th, 2006 at 10:51 PM.
    \"Those of us that had been up all night were in no mood for coffee and donuts, we wanted strong drink.\"

    -HST

  8. #8
    Senior Member
    Join Date
    Jan 2003
    Posts
    3,914
    Hey Hey,

    To have a full blown root account in Ubuntu is rather simple..

    sudo passwd root
    <enter your password for sudo>
    <assign a root password>

    To setup file sharing on Ubuntu and derivatives is just as simple..

    I just shut down my Ubuntu laptop (heading home for the day), however it's as simple as right clicking on the folder you want to share and going to sharing... Tell it to share with Samba, provide a password and it will make the necessary config file changes... Very similar to doing it in Windows...

    I'm also moving this to Operating System Discussions... since it's not security.

    Peace,
    HT
    IT Blog: .:Computer Defense:.
    PnCHd (Pronounced Pinched): Acronym - Point 'n Click Hacked. As in: "That website was pinched" or "The skiddie pinched my computer because I forgot to patch".

  9. #9
    Gonzo District BOFH westin's Avatar
    Join Date
    Jan 2006
    Location
    SW MO
    Posts
    1,188
    You must spread some Reputation around before giving it to HTRegz again.

    Thanks... I was making that way harder than it should have been.
    \"Those of us that had been up all night were in no mood for coffee and donuts, we wanted strong drink.\"

    -HST

  10. #10
    Agony Aunty-Online Moira's Avatar
    Join Date
    Jun 2003
    Posts
    1,063
    It's still bloody annoying I right click "desktop" say, select sharing and "configure file sharing". It wants a password, so I give it one and I get a wonderful greyed out box up, containing all the options I want, except they're greyed out. "Enable local network sharing" either in simple or advanced form is there but can I hell access them! It's just greyed out, what kind of password is it looking for??

    Where and what would I see on XP anyway? If I browsed the network would kubuntu magically appear? Looking at my saved samba file, I really wish I could copy it across.

    I had moderate success in a terminal. I got root permission doing sudo -H -i, but every command I tried, I just got "could not start".

    "cannot start smb.conf"

    cp /etc/smb.conf /etc/smb.bak

    "cannot start" ... etc

    Then there appears to be no sort of link between what I'm doing in the terminal and a file I'm attempting to right click and set sharing (?)
    Last edited by Moira; November 27th, 2006 at 11:44 PM.
    77 111 105 114 97

    My PGP signature

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •