open pix outbound telnet port
Results 1 to 5 of 5

Thread: open pix outbound telnet port

Hybrid View

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Posts
    2

    open pix outbound telnet port

    I have a Pix 515 configured with no outside internet access, the main thing that Pix is used for is vpn between 2 remote branch offices.
    *I need to open outbound traffic on workstation 10.10.200.201 to use telnet to public ip XX.XX.XX.XX. Any help would be appreciated. Thanks in advance. Here is a copy of my config

    Building configuration...
    : Saved
    :
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto shutdown
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 intf2 security4
    enable password ************** encrypted
    passwd ******** encrypted
    hostname ABCD
    domain-name ABC
    clock timezone CST -6
    clock summer-time CDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 10.12.0.0 remte1
    name 10.10.70.41 Syslog
    access-list outside_cryptomap_20 permit ip 10.10.0.0 255.255.0.0 10.11.0.0 255.255.0.0
    access-list inside_nat0_outbound permit ip 10.10.0.0 255.255.0.0 10.11.0.0 255.255.0.0
    access-list inside_nat0_outbound permit ip 10.10.0.0 255.255.0.0 SIBZ 255.255.0.0
    access-list outside_cryptomap_40 permit ip 10.10.0.0 255.255.0.0 SIBZ 255.255.0.0
    access-list 101 permit tcp host 10.10.200.201 host x.x.x.x eq telnet
    pager lines 24
    logging on
    logging timestamp
    logging trap warnings
    logging host inside Syslog
    icmp deny any outside
    mtu outside 1500
    mtu inside 1500
    mtu intf2 1500
    ip address outside x.x.x.x x.x.x.x
    ip address inside 10.10.17.77 255.255.0.0
    no ip address intf2
    ip verify reverse-path interface outside
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 10.0.0.0 255.0.0.0 inside
    pdm location 10.11.0.0 255.255.0.0 outside
    pdm logging warnings 100
    pdm history enable
    arp timeout 14400
    nat (inside) 0 access-list inside_nat0_outbound
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 10.10.0.0 255.255.0.0 inside
    http 10.11.0.0 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer x.x.x.x
    crypto map outside_map 20 set transform-set ESP-AES-192-SHA
    crypto map outside_map 40 ipsec-isakmp
    crypto map outside_map 40 match address outside_cryptomap_40
    crypto map outside_map 40 set peer x.x.x.x
    crypto map outside_map 40 set transform-set ESP-AES-192-SHA
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address x.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address x.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption aes-192
    isakmp policy 20 hash sha
    isakmp policy 20 group 5
    isakmp policy 20 lifetime 86400
    telnet 10.10.0.0 255.255.0.0 inside
    telnet timeout 15
    ssh timeout 5
    management-access inside
    console timeout 0
    username ****** password ******* encrypted privilege 15
    terminal width 80
    : end
    [OK]

  2. #2
    Senior Member
    Join Date
    Sep 2001
    Posts
    1,027
    You need a normal nat entry to enable inside traffic to leave on the outside interface.

    Ammo
    Credit travels up, blame travels down -- The Boss

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Posts
    2

    Outbound port?

    Do you know if I add these two lines if that would allow outbound telnet traffice from that ip?

    access-list inside_out permit tcp host 10.10.200.201 eq telnet host xx.xx.xx.xx any

    nat (inside) 0 access-list inside_out

  4. #4
    Senior Member
    Join Date
    Sep 2001
    Posts
    1,027
    Not quite:

    You'll need to define a global pool and use it in your nat instead of the nat "0" which tells the pix NOT to nat on traffic matching that acl...

    Should look something like this:

    access-list inside_out permit tcp host 10.10.200.201 eq telnet host xx.xx.xx.xx any
    global (outside) 1 outside
    nat (inside) 1 access-list inside_out

    There are variants on how to accomplish this (check the command references for PIX on cisco's website) but this should work.


    Ammo
    Credit travels up, blame travels down -- The Boss

  5. #5
    Right turn Clyde Nokia's Avatar
    Join Date
    Aug 2003
    Location
    Button Moon
    Posts
    1,696
    Hi Smokey,

    Policy NAT would help you out - I think that is what you are trying to use from the commands you posted, you just have the ACL syntax wrong a touch is all as it differs slightly when using policy NAT.
    access-list TELNET permit tcp 10.10.200.203 255.255.255.255 XXX.XXX.XXX.XXX 255.255.255.255 eq telnet
    nat (inside) 1 access-list TELNET
    global (outside) 1 <external IP> or <interface>
    Depending on the setup you have you can use either the interface IP address, by giving the command 'interface' on the Global statement, if you are not already using it to PAT anything - if you are you will need a separate IP to use for NAT as obviously the same IP address can not be used to NAT and PAT simultaneously.

    Obviously you can call the ACL anything you want as it does not get applied directly to the interface and the NAT-ID should be changed if needed to fit in with your configuration.

    Does the remote office you VPN to have internet access? If so you could maybe just route through the VPN and use the NAT setup that will already be there.
    Last edited by Nokia; November 30th, 2006 at 07:48 PM.
    Drugs have taught an entire generation of kids the metric system.

    http://tazforum.**********.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •