Defective HDD Diagnostics?
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Defective HDD Diagnostics?

  1. #1
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190

    Defective HDD Diagnostics?

    Hi folks, I have just come across an interesting one, and thought I would throw it in for comment and suggestions.

    The Computer is a Dell Dimension 8100, P4/1.7Ghz, 764Mb PC800 RAMBUS, nVidia graphics 64Mb, Turtle Beach sound card. 60Gb 7,200 rpm HDD.

    Running Windows ME on a FAT32 filesystem. It started to play up all of a sudden, not booting and so on. Sometimes just a black screen with the options F1 to retry and F2 to enter BIOS setup.

    If you go for F1 it just repeats the message on a new line. F2 indicates that the HDD is not detected.

    Booting from the Win ME rescue disk and then rebooting Windows lets me get into safe mode and run scandisk (won't complete in normal mode) but that doesn't find anything unusual, just file fragments/orphans and a couple of cross-linked files (temporay ones at that).

    I got it to boot into normal mode, but it blue screens after a while and gives the enigmatic "unable to write to disk in drive C"

    I took the HDD out and slaved it to my Win XP box............... that was a laugh and a half. It wasn't recognised at first so I went into setup and fixed that. It correctly identified the HDD as a slave, and got the model and specs right It also set my processor from an AMD Athlon XP 1900+ to a 1200Mz Athlon processor?......................I cannot even do that in the BIOS!!!!

    When I reset the processor (it still showed as a 1900+) in the setup.........all I could do was click on the setting and accept it............the slave HDD was no longer recognised. It started to crash the XP box when I tried setting it to "auto" or to "user"

    Strangely, when it lets you into "user" it won't let you set any of the values

    I tried the Data Advisor 5.0 software from Ontrack and all that found were a couple of file fragments. Even after an 8 hour surface scan.

    I got the Hitachi "Drive Fitness Test" and ran it in "advanced test mode" This gave me a result code of 0x73, which means "Defective device: excessive shock" which is total crap. I then ran the "quick test" which gave a code of 0x00, which means everything is hunky dory.

    I ran the advanced test again and it also gave 0x00

    So much for Hitachi diagnostics.

    I tried the usual fixmbr ploy as well, but it didn't make any difference.

    The drive is an IBM IC35L060A VER07-0 (built in May 2001), but that IS NOT the issue here

    Any ideas or suggestions?



    Any ideas or comments
    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  2. #2
    Senior Member IKnowNot's Avatar
    Join Date
    Jan 2003
    Posts
    792
    Sorry, but I am at a loss.

    I can say I found similar problems, but not all together like yours.

    The first was with an e-machine running ME.
    Same exact initial symptoms, but different drive manufacturer. I was lucky that I could save most of the information before it crapped out totally, reinstalled the OS on another drive, etc. to get the machine back up. I then did a complete erase of the original drive ( all 0's ), started from scratch and have been running linux on that drive for a couple of years. I never could find what caused it. The not being recognized by the BOIS some of the time really threw me.

    The second ( arrived to me dead, and also sometimes not being recognized by the BIOS or configuration was all wrong, and played with my MB BIOS, etc. ) was a similar drive to yours ( Hitachi/IBM DeskStar ) with ME on it. I made the same attempts with the Drive Fitness tool ( ver. 4.06 ), even tried in desperation the Feature tool. Nothing would work on that drive, even though it checked clean with their tool.
    ( BTW, the box that had the MB BIOS screwed with was a Dell Dimension too, but it was not the original drive in that machine. I also tried it on an old TYAN MB machine, and although similar results, no changes observed with MB settings. )

    I did notice when searching back then that there were some firmware upgrades to some of the old DeskStar line, and a lot of complaints; I don't know if that is relevant.

    I wound up tossing that drive.
    ( and did a MB BIOS reinstall just to be safe. )
    " And maddest of all, to see life as it is and not as it should be" --Miguel Cervantes

  3. #3
    AOs Resident Troll
    Join Date
    Nov 2003
    Posts
    3,152
    How about the old harddrive in the freezer trick...

    It actually worked once for me....not sure if it was just letting the drive cool down for a bit...or it was the freezer trick that did it...but I got it to spin one last time....

    Only worked once though...have tried if a few times....they have some other tricks....may wanna try...cant hurt

    http://www.trap17.com/index.php/hard...ck_t26193.html

    MLF
    How people treat you is their karma- how you react is yours-Wayne Dyer

  4. #4
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190
    Hi Morgana~, the freezer trick isn't appropriate here because the drive still spins and is plainly readable in DOS.

    I just updated the BIOS but with no luck
    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  5. #5
    Dissident 4dm1n brokencrow's Avatar
    Join Date
    Feb 2004
    Location
    Shawnee country
    Posts
    1,242
    I ran into a somewhat similar situation recently with a DOA harddrive from
    my brother. I'm a big fan of IDE-to-USB cables and hooked his HDD up to
    my primary laptop, a P4 Toshiba. Wouldn't read it. Nada. Recognized the
    hardware, but not completely. Couldn't run chkdsk, never picked up on the
    filesystem. Then a couple of days later, I tried it on my secondary laptop,
    a PIII IBM, and it picked up the HDD and read the file system. Even ran
    chkdsk. I even got a data recovery. Same cabling. The only difference
    I could find was USB versions (2.0 vs. 1.1).

    As for diag's, you can never trust them completely. Wrestled most of the
    day yesterday with a user's Lenovo laptop, ran PC Doctor overnight. PC
    Doctor has the hardware as good, no problem. So I re-image the guy's unit,
    and it's still locking up, 15 minutes at a time. Noticed the bottom of the unit
    was hot as Hell...er...a Dell. So I called support and got a box (it's under
    warranty). Told tech support it was a thermal issue and the CPU/systemboard
    needed replacing. The diagnostics were worthless in this case (not the first
    time).
    Last edited by brokencrow; May 25th, 2007 at 02:15 AM.
    “Everybody is ignorant, only on different subjects.” — Will Rogers

  6. #6
    AOs Resident Troll
    Join Date
    Nov 2003
    Posts
    3,152
    How about a parallel install

    Change the install dir to "xpnew" or something ...then grab the data???

    Then format\reinstall the OS..........2000 is way better then ME...

    no activation

    MLF
    How people treat you is their karma- how you react is yours-Wayne Dyer

  7. #7
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190
    Hi, Morgana~,

    This is quite a strange one, that I have never encountered before, and I have seen a lot of dead hard drives in my time.

    Since my last report, I did a Registry repair, removed the 56.6 voice/fax/data modem, and turned off the IRQ handling................still with the same problems.

    I boot into DOS and run Scandisk from that. It will do the standard (fast) check OK, so I thought I would let it try a surface scan (It could be my imagination, but I always felt that Scandisk found more if you ran it in DOS?)

    Aha! I see 6 damaged clusters with 196,608 worth of space in them.......... from my estimation, this is in the disk area that I would imagine Billy Windoze to be occupying?

    So, I rerun the DOS Scandisk, and set it to do a surface scan (yeah! I know....a 60Gb HDD and DOS!..............zzzzzzzzzzzzzzzzzzzzzzzz)

    It passed the first bad cluster with no problems but came to the second one and stopped dead..........??????????? I guess that must be something to do with the problem?
    Thinking that tools using Caldera DOS (SCO ) and IBM PC DOS will surface scan OK, I wondered if that might be part of the problem?

    So, I stuck a Maxtor 40GB in as primary, and loaded Win ME........... thanks Dell, your backup and recovery CDs are about as much use as teats on a boar..............more of that later..................

    I then jumper the "Deathstar" as a slave and install that. Hey, it works fine (as a slave) and I can read all the data on it (albeit at 480x640 and 16 colours) which sort of confirms my suspicions that there is some kind of fatal corruption of Windows? [Incidentally, I had tried a replace installation of Win ME and that hung as well].

    I have been loading apps software, and now know just how unsupported Win 9x/ME has become................ in particular with firewalls.

    So, I think that what I will try to do is reformat the drive, and try it with something else. Windows 2000? yes, I have several unused instances (with the little MS sticky labels)............. but I also found Lindows/Linspire.......... I wonder if it is possible to dual boot Linspire and Windows 2000 (5 seat Server edition)???????????

    It is my wife's machine

    Incidentally, my bitch about Dell was that their recovery disks did not allow me to reinstall the nVidia GeForce3 card that they installed in the box. I got the latest management tool from the nVidia site and it installed the card and even reset the display to 600x800 and 16 bit colour! That being its idea of minimal settings........ not 480x640 and 16 colours................

    At the end of the day, the drive is still potentially useful, as the controller card is fine, and I have had a good rate of success in replacing those, where I could find an identical match. This is a potential donor?

    I will report back with progress (when not seeing my divorce lawyer?)

    Cheers
    Last edited by nihil; May 26th, 2007 at 01:27 PM.
    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  8. #8
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,190
    Well, here is an update:

    1. I have now installed most of what I had, apart from rubbish games and obsolete applications tests. I did have to get an updated version of WinInstall though for some items. I guess that had been done as part of the Windows updates somewhere down the line.

    2. All that is left is activating the ADSL connection, installing the printer, and installing Office XP (2002)

    3. Then reloading the personal data folders...................all 5 3.5" floppies worth..............I couldn't be bothered to go get a CD

    It has taught me a lesson though. I have now created the files to let me do a cumulative install of the SPs and other updates to Windows 2000, plus the latest versions of the Apps.

    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  9. #9
    Keeping The Balance CybertecOne's Avatar
    Join Date
    Aug 2004
    Location
    Australia
    Posts
    659
    Its possible that the harddrive is faulty with a loose bearing. This has the affect of appearing fine and working without any problems, until it starts to wobble again. The freezer trick works well in this scenario because the temperature shrinks the metal and tightens the bearing.

    If this is the case, then it would explain why you are getting an error message, and then an all clear message one after the other with the diagnostic test. It would also explain scandisk drop outs..... Problem is with this issue, the more diagnostics you run typically the worse the problem will get.
    It also set my processor from an AMD Athlon XP 1900+ to a 1200Mz Athlon processor
    Can't account for that though.... I assume its an IDE Drive?
    "Any intelligent fool can make things bigger and more complex... It takes a touch of genius --- and a lot of courage to move in the opposite direction."
    - Albert Einstein

  10. #10
    Member
    Join Date
    May 2005
    Posts
    93
    speaking of HDD, i downloaded a software called HDD Health and it shows that the nearest T.E.C. (Threshold Exceeds Condition - supposed date when this attribute achieves threshold value, in other words probable date of end of HDD life.) of my 80G Seagate hard drive (slave) is on 2020. And it shows there too that my hard drive is having a problem which is true bcoz it hangs my computer unexpectedly.

    an officemate came to me last month and told me that her computer doesn't load its OS(XP) anymore. When i check her computer and go to the CMOS her HDD wasn't detected anymore. i've tried to get her HDD and put it in my computer and configured it as a slave but to no avail her HDD wasn't there. I advice her to bring her HDD to the computer company where she bought it and have it fixed but it didn't too.

    Is it be possible that the HDD was infected with virus or the memory does something to do with this?
    The computers memory is only 128MB with 120G HDD.

    Excuse my english. lol. thanks.
    .sig na ture.

Similar Threads

  1. CPU Diagnostics
    By Darksnake in forum Hardware
    Replies: 1
    Last Post: November 27th, 2005, 11:16 AM
  2. Dell Won't Recall Defective Mobo's
    By hesperus in forum Hardware
    Replies: 4
    Last Post: August 31st, 2005, 05:07 PM
  3. Replies: 82
    Last Post: August 31st, 2004, 10:05 PM
  4. IP / Network Name Scan - Diagnostics
    By unonthedl in forum Newbie Security Questions
    Replies: 10
    Last Post: March 1st, 2004, 12:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •