fun with wifi and the nighbors...
Results 1 to 7 of 7

Thread: fun with wifi and the nighbors...

Hybrid View

  1. #1
    Member
    Join Date
    Oct 2006
    Posts
    63

    fun with wifi and the nighbors...

    in one of my browsing session I came across this article and after setting up the dhcp and squid server, I can't get the perl script to work as intended....could anyone take a look at this article and tell me if this is possible

    thanks

  2. #2
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    Yes, it's possible. What trouble are you having with the perl script?
    My first bet is you're missing mogrify, that's part of ImageMagick.
    Oliver's Law:
    Experience is something you don't get until just after you need it.

  3. #3
    Member
    Join Date
    Oct 2006
    Posts
    63
    Quote Originally Posted by SirDice
    Yes, it's possible. What trouble are you having with the perl script?
    My first bet is you're missing mogrify, that's part of ImageMagick.
    after installing it, still have trouble running it...I'm running the script as
    #perl /etc/squid/redirector.pl....it seems to be running and I have mogrify, because I see it when I execute it at terminal...but webpages are served just fine...any ideas?

    thanks
    ps: I couldn't get the iptables running...but I figure it should work the same

  4. #4
    Senior Member IKnowNot's Avatar
    Join Date
    Jan 2003
    Posts
    792
    I couldn't get the iptables running...but I figure it should work the same
    You did not say what your problem was with it.

    First, distros put iptables in diferent directories.
    ( example: could be in /sbin or /usr/sbin )
    Try
    which iptables
    to find out where it is on your system.
    Also make sure it is started!

    Second, make sure network addresses you are using match your setup!
    " And maddest of all, to see life as it is and not as it should be" --Miguel Cervantes

  5. #5
    Member
    Join Date
    Oct 2006
    Posts
    63
    Quote Originally Posted by IKnowNot
    You did not say what your problem was with it.

    First, distros put iptables in diferent directories.
    ( example: could be in /sbin or /usr/sbin )
    Try
    which iptables
    to find out where it is on your system.
    Also make sure it is started!

    Second, make sure network addresses you are using match your setup!
    when I said iptables I was talking about getting the routing done, to achieve the transparent squid server.....yes my network config is ok, I'm testing it with a laptop and is getting appropiate ip and is browsing through the squid server, I setup the browser for use with proxy, but I'm not getting the pictures flipped over

    thanks

  6. #6
    Member
    Join Date
    Oct 2006
    Posts
    63
    you were right I was missing the ImageMagic program, but now my squid server is not serving request anymore, although is working I can see the port 3128 open on my server, but clients are getting page not found...uhh

  7. #7
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    The whole transparent proxy setup is the trick that makes it all work. The upside-down pictures are just a gimmick..
    Oliver's Law:
    Experience is something you don't get until just after you need it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •