So I ran into a funny thing the other day.

I was trying to back up a user's data to another hard drive before reimaging his laptop, just doing a simple copy/paste from one drive to another, when I ran into an odd error. Basically halfway through the copy, the process would hault with an error saying something down the lines of I could no longer write to the drive. I'd test the drive I had up until this point successfully copied data to by trying to simply create a new folder. Sure enough, I'd get an error saying I suddenly don't have permission to the drive.

After powering the drive off and back on again and reconnecting USB, the error would cease, and I could create a new folder again. Restarted copying data...halfway through, same error, and again, afterwards, could no longer create folders.

So my first hunch was the drive was going bad. So I used one of my usual diag tools to run tets on it. I've grown rather fond of Western Digital's WD Diagnostics uitlity, so I usually use it, as was the case here. Ran quick test, extended test, and write zeros test...everything passed, no problems.

So I'm wondering, what else should I do to further test the drive? Any ideas as to what else could have caused that oddity to pop up? (FYI, it's a Hitachi 5400rpm 40GB laptop HDD).