IDE makes me suicidal
Results 1 to 4 of 4

Thread: IDE makes me suicidal

  1. #1
    0_o Mastermind keezel's Avatar
    Join Date
    Jun 2003
    Location
    Atlanta
    Posts
    1,024

    IDE makes me suicidal

    So I was attempting to get a faulty IDE HD, an aged IDE Optical drive (on the same data ribbon b/c there is only one IDE input on the board) working together in my fairly recent desktop. My primary hard drive is SATA. For starters, jumper settings apparently override everything in the BIOS. *facepalm* Also, there is no jumper setting on a SATA drive, therefore unless it is designated primary in the BIOS....it's a pushover. If I set them both (IDE HD and Optical drive) to cable select, neither show up. If I set the optical drive to Master and the HD to Slave, the HD shows up and behaves but the optical drive doesn't. If I set the Optical drive to slave and the HD to master, they both show up and seem to work but then the IDE HD completely overrides the SATA drive and it engages in the never ending disk-check that I can't even opt out of because it takes so freaking long for it to load drivers for my USB keyboard.

    I ordered a decent SATA CD/DVD burner earlier which should be here in a couple of days so I won't even have to worry about it, but it was interesting to run into such a headache.

    At some point I want to *attempt* to repair this screwed up HD if possible and load linux on it rather than partition off my primary HD. Any suggestions? Most of this I just figured I'd share, but if anyone has some thoughts that could help me out I'm quite open to advice.

  2. #2
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    SATA doesn't have master/slave. It's dependent on which connector you use. Set the IDE drives correctly, HD on master and CD on slave.

    There should be a boot order switch in you BIOS. That will tell which drive to boot from. I have a machine with SATA and IDE harddisks and it boots of the SATA without any problems.

    NB If the IDE disk has any bad sectors on it, throw it away.
    Oliver's Law:
    Experience is something you don't get until just after you need it.

  3. #3
    Super Moderator: GMT Zone nihil's Avatar
    Join Date
    Jul 2003
    Location
    United Kingdom: Bridlington
    Posts
    17,178
    Hi folks,

    I am suspecting that the fact that the IDE HDD has problems of its own might be a part of the issue?

    I would forget the optical drive. Create a folder on your SATA drive with your diagnostic and repair tools in it. I would use the ones from the manufacturer rather than Windows

    With the SATA as the master/boot and the IDE as slave you should be able to run the diagnostics/repair from the SATA drive.

    As SD~ says, if you find bad sectors then the drive cannot be trusted. Personally, I keep them if the motherboard is OK, which this one is. I have made some good friends and some serious money replacing HDD MoBos and recovering the data
    If you cannot do someone any good: don't do them any harm....
    As long as you did this to one of these, the least of my little ones............you did it unto Me.
    What profiteth a man if he gains the entire World at the expense of his immortal soul?

  4. #4
    Dissident 4dm1n brokencrow's Avatar
    Join Date
    Feb 2004
    Location
    Shawnee country
    Posts
    1,242
    Try a USB-to-IDE cable to run chkdsk. Works for me all the time.
    Everybody is ignorant, only on different subjects. Will Rogers

Similar Threads

  1. Tcp/ip
    By gore in forum Newbie Security Questions
    Replies: 11
    Last Post: December 29th, 2003, 07:01 AM
  2. I caught a Virus! ......Can I play with it?
    By One Who Watches in forum AntiOnline's General Chit Chat
    Replies: 4
    Last Post: July 20th, 2003, 11:09 AM
  3. Deleted since went suicidal
    By bugsthecat in forum AntiOnline's General Chit Chat
    Replies: 3
    Last Post: May 25th, 2003, 10:10 PM
  4. Suicidal threads due to others fault...
    By -DaRK-RaiDeR- in forum Site Feedback/Questions/Suggestions
    Replies: 7
    Last Post: January 21st, 2003, 01:33 AM
  5. The Worlds Longest Thread!
    By Noble Hamlet in forum AntiOnline's General Chit Chat
    Replies: 1100
    Last Post: March 17th, 2002, 08:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides