Hey Larren,

to get your folder option back

from start menu open run command in that type regedit.exe

in that go HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

in that there would be a file named NoFolderOption just right click on it and change the value to 0 or simply delete the key file

and then after saving restart the computer and you will find your missing folder option back

best of luck