Results 1 to 6 of 6
  1. #1
    Blast From the Past
    Join Date
    Jan 2003

    TFTP error code 2, 3rd party firmware on a linksys router

    Hey everyone!

    I have been trying to get answers on dd-wrt's forum, dd-wrt is the 3rd party firmware I am loading on my wrt54g v8 router... and it seems no one there knows about my issue, let alone as even encountered it themselves.

    So I am following the tutorial for my version router with all the correct firmwares downloaded.

    First I hold the reset button and put the router in firmware reset mode... I use the GUI interface as instructed to load the vworkskiller firmware.. this will allow you to load a custom firmware on the router. This part goes without a hitch (or so I believe)

    Then I come to the point where I TFTP into the essentialy blank router, the vworkskiller firmware providing tftp access..

    I have my computer setup with a static IP, hardwired to LAN port 1 on the router. As instructed.

    Now, here is where I run into problems.

    I go to tftp the new firmware to the router, I was running on my macbook at the time.

    tftp -e
    >put dd-wrt.v24_micro_generic.bin
    error code 2: Access violation.

    I search dd-wrt wiki, old forums, and new forums... there isnt even a database of troubleshooting with common errors. SO I post on the forums my anguish, following the sticky post as to how I have to post to get results... and i get none.

    I have been googling.. but the best I can come up with is "Refer to your manufacture's documentation for further information about your error codes".. straight from a cisco PDF about tftp error codes..

    So here is my thought process with what i know about tftp
    TFTP does not use user authentication.
    I have tried some other variants of the tftp command.

    put dd*blah /dd*blah
    put " /tftpboot/blah
    put " /boot/blah

    in an attempt to see if the directory in witch I am tftp'ing into is just not writeable.

    I have tried this on multiple operating systems.. xp.. vista.. osx tiger, slackware 10.... same error

    I have made the binary completely writeable and readable... chmod 777...

    I have tired running tftp as an administrator, super user, regular user, no permissions user.

    I have no way to find out the file structure on the router and I can not seem to find proper documentation for my step of flashing the router. there is plenty of info AFTER i get dd-wrt on there.. and BEFORE i get the vworkskiller firmware uploaded.. but the middle road between is one big mystery that seems to work for most everyone except me (haha)

    One thing I have been considering is I may have the version of my router incorrect.
    From what I can tell I have a version 8..

    v8 and v8.2 are simple to flash.. v8.1 has a unique method.. I had found a website which I can not locate again for the life of me that explained the differences between v8, 8.1 and 8.2... I would bet money mine was v8 but I would like to double check.

    So really where I want to get started is to have someone that knows about TFTP explain why someone could recieve Error code 2: Access Violation and how to fix that issue.

    I am still heavily browsing the dd-wrt forums and hoping a fish will bite my Thread (Ha!) but Im not holding my breath.

    Thanks for any input in advance! and I hope the AO Community is doing well!
    work it harder, make it better, do it faster, makes us stronger

  2. #2
    Senior Member
    Join Date
    Sep 2001
    Try a shorter filename
    Credit travels up, blame travels down -- The Boss

  3. #3
    Blast From the Past
    Join Date
    Jan 2003
    shortened the name to dd-wrt.bin, still the same error

    also tired ddwrt.bin, still no go
    work it harder, make it better, do it faster, makes us stronger

  4. #4
    Blast From the Past
    Join Date
    Jan 2003
    so i Just ran a hard reset on the unit... and suprisingly the factory firmware was still there!

    from my understanding it should be gone with the use of vxkiller... which leads me to believe it never retained the original flash... odd..

    oh well, il mess around with this some other time. Thanks all!
    work it harder, make it better, do it faster, makes us stronger

  5. #5
    Just Another Geek
    Join Date
    Jul 2002
    Rotterdam, Netherlands
    Two things could be the problem..

    a) the tftp server on the router only accepts get. Probably need to reconfigure it to allow writes

    b) because tftp has no authentication the file you are writing to needs to exist. A simple touch destinationfile will create an empty file. After that you should be able to write.
    Oliver's Law:
    Experience is something you don't get until just after you need it.

  6. #6
    Blast From the Past
    Join Date
    Jan 2003
    I got it working!!

    I am not sure what went wrong first time around.. I guess the vxworkskiller flash didnt take the first time through.

    Second time I followed the directions just as I did before and bam! works great!

    didnt have to touch, the put command worked without an error.
    work it harder, make it better, do it faster, makes us stronger

Similar Threads

  1. Replies: 6
    Last Post: November 10th, 2005, 10:53 PM
  2. Linksys Router Owners - HEADS UP!
    By thehorse13 in forum Network Security Discussions
    Replies: 31
    Last Post: June 8th, 2004, 08:19 AM
  3. Services Behind Linksys Routers
    By SonofGalen in forum The Security Tutorials Forum
    Replies: 9
    Last Post: February 6th, 2004, 12:13 AM
  4. anyone want to help me with some cisco hw?
    By Simo in forum Miscellaneous Security Discussions
    Replies: 7
    Last Post: October 28th, 2003, 02:47 PM
  5. Linksys Router Configuration Tutorial
    By Ratman2 in forum Other Tutorials Forum
    Replies: 6
    Last Post: June 20th, 2002, 10:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.