Help
Results 1 to 4 of 4

Thread: Help

  1. #1
    AO's MMA Fanatic! Computernerd22's Avatar
    Join Date
    Mar 2003
    Location
    Miami, FL
    Posts
    778

    Help

    Hello fellow members of AO. Been a while since a last post anyways. Heres the issue. My friend is running windows xp with ie 8 and everytime he opens his "internet explorer" and after the page loads it displays this message;



    A Program on your computer has corrupted your default search setting for Internet Explorer.

    Internet Explorer has reset this setting to your original search provider.

    Internet Explorer will now open Search Settings, where you can change this setting or install more search providers.

    Basically, giving him a Search Default Provider Error every time he opens IE.

    His default is yahoo. he already has a search provider on his browser. Anyways, I had him open IE, click on tools and down to manage add-ons, then to search providers. We set yahoo as the default, and got rid of the other search providers only leaving yahoo, closed ie & re opened it still same error. Rebooted system, and reset "IE" to the factory settings under the *advanced tab* in internet options. I searched the net and found some registry tweaks but I'm kind of iffy on that with someone elses computer. ----> Is there a way to get rid of this error message everytime he opens IE, all help is greatly appreciated.

    P.S the guy is not a fan of mozilla so i'm pretty sure he wants to stick to IE.

  2. #2
    Banned
    Join Date
    Nov 2002
    Posts
    677
    Reading these instructions will take longer than making the actual keystrokes…

    To add the new expandable string value in the Windows Registry -

    A) while in the Registry Editor find and highlight the registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    B) “right click” on the highlighted key (which is named “User Shell Folders”

    C) select “New” on the next menu

    D) select “Expandable String Value”
    This will add a “new value” the right side of the registry.

    E) Right click on the “name” for this new value in the right side of the registry

    F)”Rename” the new value “AppData”

    G)”right click” on the value name “AppData” you just created

    H) “Modify” the value by entering “%USERPROFILE%\Application Data” in the “value data” field. Enter just as shown here, do not change any characters (leave out the ” ” ). You might want to cut and paste the character string to avoid typos.

    I) Click Ok and you should have a new line on the right side of the registry with a name of “AppData”, type “RG_EXPAND_SZ” and a Data entry of “%USERPROFILE%\Application Data”.

    J) Close the Registry

    K) Close and reopen MS IE8 to confirm the fix

    You’ll end up with two string values named “AppData” under the “User Shell Folders”, but I haven’t had any problems with any conflicts yet…YMMV

    hope this helps

    http://tinyurl.com/nvzg7c

    Have a nice day!
    Last edited by Linen0ise; August 30th, 2009 at 04:34 PM.

  3. #3
    AO's MMA Fanatic! Computernerd22's Avatar
    Join Date
    Mar 2003
    Location
    Miami, FL
    Posts
    778
    It already exists in the registry. Thanks though. I'm thinking of un-installing ie 8 and re-installing IE 7. At this point I don't think he even cares he just wants his stuff fixed and that message gone. He has two computers and both of them are having this issue. I am still currently searching the net trying to find a fix for this issue. Also, it seems this is a pretty common issue with XP users who did the windows update to IE 8. Anyways, anyone else have any other ideas a way to get rid of this message for good.


    PS I tried running IE 8 with no add-ons but certain things on net do not function right such as poker from pokerstars.net or zynga hes a big fan of poker.

  4. #4
    Banned
    Join Date
    Nov 2002
    Posts
    677
    Maybe this will help. I would also check the registry to see what apps startup with Winblows.

    April 6th, 2009 at 08:04 | #18
    Reply | Quote

    in response to steve preston. I had the existing string. and the solution didn’t work first time.
    I just typed in the string below the existing one again as in kirbs solution. works fine. I am using XP.
    April 8th, 2009 at 14:42 | #20
    Reply | Quote

    In response to robinb of 6 April….Did what you suggested by just adding it below the existing string..Works fine now..
    Thanks alot..appreciate it!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •