Results 1 to 1 of 1
  1. #1
    Gonzo District BOFH westin's Avatar
    Join Date
    Jan 2006
    SW MO

    Ettercap DNS_Spoof Problem

    Hey folks,

    I have been playing around with the dns_spoof plugin in ettercap. For the life of me, I cannot get it to start. It stalls out at:

    Randomizing 255 hosts for scanning...
    Scanning the whole netmask for 255 hosts...
    * |==================================================>| 100.00 %
    6 hosts added to the hosts list...
    ARP poisoning victims:
     GROUP 1 : ANY (all the hosts in the list)
     GROUP 2 : ANY (all the hosts in the list)
    Starting Unified sniffing...
    Text only Interface activated...
    Hit 'h' for inline help
    Activating dns_spoof plugin...
    I have tried in text and graphical mode, but both do that. I have tried on my desktop running Ubuntu, a Backtrack4 VM, and another iBook running debian. All of them do the same thing. I have tried with the example etter.dns file, and with another that I created:

    google.com     A
    *.google.com  A
    www.google.com     PTR
    [ == yahoo.com]

    Nothing seems to work. Am I missing something?

    This is what I used to start the text mode:

    sudo ettercap -i eth0 -q -T -P dns_spoof -M ARP // //
    Any help would be much appreciated.
    Last edited by westin; February 13th, 2010 at 10:33 PM. Reason: dyslexia
    \"Those of us that had been up all night were in no mood for coffee and donuts, we wanted strong drink.\"


Similar Threads

  1. The Problem Saga Continues
    By The Texan in forum Operating Systems
    Replies: 16
    Last Post: June 22nd, 2006, 08:04 PM
  2. A Headache of an Email Problem
    By AngelicKnight in forum General Computer Discussions
    Replies: 14
    Last Post: June 15th, 2006, 04:04 AM
  3. 500 mile email problem
    By Tedob1 in forum Tech Humor
    Replies: 0
    Last Post: December 23rd, 2002, 03:58 PM
  4. C problem...
    By Rna in forum General Programming Questions
    Replies: 4
    Last Post: May 22nd, 2002, 07:03 AM
  5. Help! I've got a nasty IDE problem
    By thesecretfire in forum Hardware
    Replies: 16
    Last Post: May 17th, 2002, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.