I have a 15' USB extension cord that I recieved when I ordered my Alfa range extender and wardriver. I went to use it for the first time today (the extension cord, not the Alfa).
What happened when I plugged the Alfa to it was I got a message that the device was not recognized, and windows couldn't find any driver software for it. At first I thought it was because, without the Alfa getting connectivity, Windows couldn't connect online to find the software.
So I moved my lappie so it had good connectivity with its factory wifi - same result.
I pulled out my trackball mouse, which I've never had problems with when I've used it. I have it set up so my touchpad auto-disables when the mouse is plugged in. This happened and the mouse worked fine through the ext. cord.
So Im thinking to myself "WTF??".
I pull out a flash drive and attach it to the ext. cord - same result as with the Alfa.

Can I get a fairly thorough explanation from someone as to what is happening inside my box for this to happen.
I'd like to get this sorted out, don't mind figuring it out myself; but it would really help my effort if I could get a good breakdown of the issues and mechanisms at work here.

Again, my USB ext cord gets unable to recognize device and device driver software not found messages when I connect anything to it other than my trusty trackball mouse. The Alfa software and the flash drive software are and have been installed and working fine - its the cord.