Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Nov 2016

    Cannot Find Module 'express' With Node.js Using DockeCannot Find Module 'express'

    I'm a newbie with Docker and I'm trying to start with NodeJS hosted in asphostportal.com so here is my question..

    I have this Dockerfile inside my project:

    FROM node:argon

    # Create app directory
    RUN mkdir -p /home/Documents/node-app
    WORKDIR /home/Documents/node-app
    # Install app dependencies
    COPY package.json /home/Documents/node-app
    RUN npm install
    # Bundle app source
    COPY . /home/Documents/node-app
    EXPOSE 8080
    CMD ["npm", "start"]

    When I run a container with

    docker run -d -p 49160:8080 node-container

    it works fine..
    But when I try to map my host project with the container directory (

    docker run -p 49160:8080 -v ~/Documentos/nodeApp:/home/Documents/node-app node-cont

    ) it doesn't work.
    The error I get is:


    Error: Cannot find module 'express'

    I've tried with other solutions from related questions but nothing seems to work for me (or I know.. I'm just too rookie with this)
    Thank you !!

  2. #2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts