Results 1 to 5 of 5

Thread: Linux suckz :D~

  1. #1
    Junior Member
    Join Date
    Oct 2001

    Linux suckz :D~

    heh kiddin' !! got a problem .. i got win2kpro installed on mah partition (NTFS) and i installed linux (Suse) on mah another IInd partion .. the foikup iz.. i am not able to boot win2k .. it sayz Invalid Disk .. heh fedup and i deleted Linux Partion .. then win2k workz perfect jus like before .. and left trace of linux-filez .. whatz the Xact prob ?! neone can help me ? *mez confused*
    -= PEACE =-
    :: Real Eyes Realize Real Lies ::

  2. #2
    Join Date
    Sep 2001
    I hope you're tired and forgot how to write properly.

  3. #3
    Senior Member
    Join Date
    Sep 2001


    With SUSE 7.3 and Win2K it should have advised you to install Lilo onto a floppy, if you did that, all should be well, the floppy (with Lilo) would boot into SUSE or Win$blows should you choose.

    Reinstall SUSE and read the screens that tell you to use a floppy (when it detects the virus better known as win2k) to install lilo onto.


  4. #4


    I had the exact same problem...

    What jcdux said will fix up your problem. Lilo gave me all sorts of headaches at the start and I came to the conclusion that it's just easier to make a boot disk and boot from that rather than your harddrive...

  5. #5
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Redondo Beach, CA


    There is one other possibility (big reason why I have DOS on development boxes). I've seen this little beauty with a multiple-boot box and seems to be an IBM machine specific thing (at least on the test boxes I've done).

    Assuming you didn't install Linux on top of the Win2K partition, sometimes, the partition #s get changed so a minor change to the partition listings in boot.ini can help.

    Below are instructions on how to make them all work happy without a boot disk (in theory but RH7.0 has been problematic with this.. haven't tried 7.1 or 7.2 or other linux distros yet). One thing to do however when installing Linux is to put the lilo on the first sector instead of the MBR. I had this instructions I think somewhere else on AO but damned if I can find them.

    1. Log into the graphical system interface as root. Press ok to the warning about using root at the console. Close the windows that open up. Looking at the bottom you will see a picture that looks like a monitor. Hit that to open a console window.

    2. Type cd /

    3. Type dd if=/dev/hdax of=/bootsect.lnx bs=512 count=1 where /dev/hdax is the harddrive info you got in step 15 of the Linux setup. Insert the other blank diskette labelled bootsect.lnx (that is BOOTSECT.LNX in lower case) for the machine in question.

    4. Type mcopy /bootsect.lnx a:

    5. Close the console window. Hit the “footprint” on the bottom right of the screen and choose logout. You will then get a closing window. Choose save settings and reboot. Remove the boot disk and reboot.

    6. When the system reboots, choose MS-DOS and get to a DOS prompt.

    7. Type attrib –s –r boot.ini

    8. Type edit boot.ini and at the end enter the following:


    Note the partition numbers. These may have to be changed if NT doesn’t boot properly. Initial lab tests showed that the partition numbering changes. The lab partitions went from partition(2)/partition(3) to partition(4)/ partition(5).

    9. save and exit out. Type attrib +s +r boot.ini

    10. type copy a:\bootsect.lnx c:\bootsect.lnx

    11. Remove the disk out of the drive and reboot. Ensure that the system can boot into Linux and NT/2000 to ensure that the dual-boot works.

    I hope this helps. You should let the rest of us know what your final solution is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts