Results 1 to 5 of 5

Thread: small prob

  1. #1

    small prob

    just got an external modem for red hat,ran wvdialconf which detected it.I created the \dev\modem sym link to the right port.Added username , isp dial in number and passsword to /etc/wvdial.conf which are all correct.But when i try to connect it says no dialtone.The phone line is going straight from computer into the wall which works perfectly with my internal modem.

    Any ideas?

    p.s. also used kppp but got same error.

    1 other thing.I sometimes run telephone line and line from internal modem into a kinda double adaptor and then into the wall and when im off-line the phone operates fine.

    But now when i run line from external modem and telephone line into same double adaptor the phone cuts out completely ( even if i leave modem switched on or off and am offline).Maybe this has something to do with it.

    but even without adaptor i still get no dial tone error.

    hope ye catch my meaning in this.Thanx

  2. #2


    Sounds like a hardware problem. sounds like the contacts in the jack are severed of the connection from the jack to the board is broken. I would suggest you take it back.

    -Hope it helps.
    Caution: in case of rapture, this computer will be unoccupied!

  3. #3
    Senior Member
    Join Date
    Jul 2001
    First, the obvious...
    Are you using a Modem Cable and not just a standard serial extension cable? Some (if not all) external modems need a special cable.

    Is the modem turned on?

    Does the /dev/modem symlink need to be "setserial"? Read "man setserial" if you don't know how to do this.

    Do you need to point to a /dev/cua* device instead of a /dev/ttyS* device? I have never used an external in Linux, but for OpenBSD, they have special device entries for external modems as opposed to interal. Anyone else know?

    Otherwise, it could be a misconfiguration, or a bad cable or connection somewhere. To check this have you tried using "minicom" to manually dial out?

    Hope this helps. Sorry I can't tell you more.

    Happy Hacking
    Warfare is the Way of deception.
    -Sun Tzu \"The Art of War\"

  4. #4
    Antionline Herpetologist
    Join Date
    Aug 2001
    Go to kppp and check your modem's initialization string. If there's a ^M there add and X0 just before it or else just add it at the end of the string. If it doesn't work, replace the X0 with and X1 and so on until X5. If this doesn't work, check back here and we'll try something else.

  5. #5
    Thank a lot lads ill give those suggestions a go

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts