Results 1 to 6 of 6

Thread: Can anyone help?? Most likly not

  1. #1
    Senior Member
    Join Date
    Dec 2001

    Question Can anyone help?? Most likly not

    Ok.... So here is the problem

    My computer was comming up with alot of critical errors going on and wanted me to send in a report to Microsoft.. Of course i said screw that and just kept on going..

    I wanted to get alot of junk off so I uninstalled a few things threw add remove and then later i restarted my computer

    Now when it restarted it said... Windows could not start because the following file is missing or corrupt:

    <Windows root>\system32\hal.dll.
    Please re-install a copy of the above file.

    Well i know hal = Hardware Access Layer
    with this is mind about a week ago I installed another hard drive but i dont see why this would start messing with me know.. I am Using Windows XP professional (lets just say that its the creative version *microsoft didnt get any money from me on this one*)

    I was trying to fix this on my own before bothering anyone so i did a search on google and basicly found nothing exept where some people where talking and had the same problem and one guy said

    I restarted win xp. and now it says that hal.dll is corrupt or missing. goddamnit! i replace the file from the i386 file.
    but then goes on to say that for him it didnt work.... I would like to try this but i am not really familiar with how to do this.

    If anyone can help it would be apreciated plus if anyone else has any other ideas

    Violence breeds violence
    we need a world court
    not a republican with his hands covered in oil and military hardware lecturing us on world security!

  2. #2
    Well i know hal = Hardware Access Layer
    it's hardware abstraction layer

    I know it has to do with your hardware architecture. The only dealings I have ever had with the HAL in in Windows 2000 Server, when using Sysprep. In order for the images to work, you need the same HAL and mass storage devices.

    and the HAL is configured based on wether you are using an Intel or AMD Processor. SO chances are if you can find the DLL make sure you have identical or nearly identical hardware as the person you are getting it from.

    About the CD thing...I dont have much experience with XP but with 2k all ya have to do is browse the .CAB files on the CD until you find the DLL file.

    but...there is a possibility of a virus. you deleting alot of stuff may have done it..but um i dont think uninstalling programs will delete your hal.dll

    well hope this helps...thought it prob wont

  3. #3
    AO Curmudgeon rcgreen's Avatar
    Join Date
    Nov 2001

    Thumbs up

    Could you have run afoul of the
    much discussed "product activation"
    feature? Copy protection can manifest itself
    in strange ways. I'm intimidated by such
    a fat OS, hundreds of megs of stuff all
    interdependent. They can sabotage
    it in dozens of different ways.
    I don't have a clue.
    I came in to the world with nothing. I still have most of it.

  4. #4
    Forgotten Ghost RogueSpy's Avatar
    Join Date
    Aug 2001
    Um. . . my friend had the same problem. . . . Want to know what he did. . . C:\ Format C: Thats about the only thing you can do.
    "Never give in-never, never, never, in nothing great or small, large or petty, never give in to convictions of honor and good sense. Never yield to force; never yield to the apparently overwhelming might of the enemy!" - Winston Churchill

  5. #5
    Senior Member
    Join Date
    Sep 2001
    Have you tried running a "repaire installation" from the CD or bootdisk? Dunno for sure, might help..


  6. #6
    Junior Member
    Join Date
    Jan 2002
    hi brothers,
    I faced the same problem.It occured when i installed debian linux in my system.I tried copying hal.dll but it didn't work.At last i used my mandrake installation cd which shows the partitions graphically.My ntfs partition it showed was the 6th one but in my boot.ini file the partition no. was 8.
    I changed boot.ini and now it is working perfectly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts