This is the story of my journey to installing my nvidia Geforce2 video card on my linux computer. This is not a happy tale and I hope others can point me at my mistakes. I first downloaded the appropriate files from the nvidia website at


I saved these files to my home directory then shut down the computer and installed the new video card. Next I turned the computer back on and logged in to bash. The readme file said to unzip the driver and I did so with

tar zxpvf NVIDIA_GLX-1.0-2313.tar.gz
tar zxpvf NVIDIA_kernel-1.0-2314.tar.gz

At this point I was to do a make install in ./NVIDIA_kernel-1.0-2314, this is where my errors began to occur. I did an su and then make install but due to errors this did not complete. I tried this again several times, but it still would not work. At that point it was late at night and I decided to shut down and resume the next day. The next day, I did a make install and it worked, but when I did a make, the computer crashed in the middle. After I got it back up, neither make or make install would work. I decided at that point to try the .rpm version of the driver. They had an rpm for my version of Mandrake so I downloaded it and the GLX . To install the rpm's I used:

rpm -ivh NVIDIA_kernel-1.0-2313.mdk81up.i686.rpm
rpm -ivh NVIDIA_GLX-1.0-2313.i386.rpm

After both of these supposedly successfully completed. I typed startx and linux immediately froze and I was forced to restart. At this point I figured I had screwed up and that I had better stop before I caused permanent damage. I removed the geforce2 and went back to using the original video card, but to my surprise xwindows now wouldnt work with it either. After going through countless config files and probably screwing things up even worse, I realized that it would take less time to back up the few files I had for linux, and reinstall than playing with the config files for another few days. This might not be the best "hacker" way to do things, but I needed my computer up soon and this was faster. After the reinstall, with the new video card, I logged in for the first time and in bash repeated the steps with the rpm files. They went off without a hitch, and this time when I typed startx, I was surprised as hell to see the kde logo. After kde loaded up, an error message appeared saying that the sound server was not functioning, so basically I went from no gui, to no sound. No prob, I can deal without for now, but the real problem occurred when I tried to mount the cdrom drive. I didnt write down the specific message, but it said that it could not read from the file system of the cdrom. So I tried the floppy drive and the same error occurred. At this point I turned my linux computer off for the night and booted up Windows98se for the first time in months. I wrote this with hopes someone can help me. Please post here, or email me at