Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Nvidia Geforce2 and linux

  1. #1

    Post Nvidia Geforce2 and linux

    This is the story of my journey to installing my nvidia Geforce2 video card on my linux computer. This is not a happy tale and I hope others can point me at my mistakes. I first downloaded the appropriate files from the nvidia website at


    I saved these files to my home directory then shut down the computer and installed the new video card. Next I turned the computer back on and logged in to bash. The readme file said to unzip the driver and I did so with

    tar zxpvf NVIDIA_GLX-1.0-2313.tar.gz
    tar zxpvf NVIDIA_kernel-1.0-2314.tar.gz

    At this point I was to do a make install in ./NVIDIA_kernel-1.0-2314, this is where my errors began to occur. I did an su and then make install but due to errors this did not complete. I tried this again several times, but it still would not work. At that point it was late at night and I decided to shut down and resume the next day. The next day, I did a make install and it worked, but when I did a make, the computer crashed in the middle. After I got it back up, neither make or make install would work. I decided at that point to try the .rpm version of the driver. They had an rpm for my version of Mandrake so I downloaded it and the GLX . To install the rpm's I used:

    rpm -ivh NVIDIA_kernel-1.0-2313.mdk81up.i686.rpm
    rpm -ivh NVIDIA_GLX-1.0-2313.i386.rpm

    After both of these supposedly successfully completed. I typed startx and linux immediately froze and I was forced to restart. At this point I figured I had screwed up and that I had better stop before I caused permanent damage. I removed the geforce2 and went back to using the original video card, but to my surprise xwindows now wouldnt work with it either. After going through countless config files and probably screwing things up even worse, I realized that it would take less time to back up the few files I had for linux, and reinstall than playing with the config files for another few days. This might not be the best "hacker" way to do things, but I needed my computer up soon and this was faster. After the reinstall, with the new video card, I logged in for the first time and in bash repeated the steps with the rpm files. They went off without a hitch, and this time when I typed startx, I was surprised as hell to see the kde logo. After kde loaded up, an error message appeared saying that the sound server was not functioning, so basically I went from no gui, to no sound. No prob, I can deal without for now, but the real problem occurred when I tried to mount the cdrom drive. I didnt write down the specific message, but it said that it could not read from the file system of the cdrom. So I tried the floppy drive and the same error occurred. At this point I turned my linux computer off for the night and booted up Windows98se for the first time in months. I wrote this with hopes someone can help me. Please post here, or email me at
    Jealousy consumes the weak.

  2. #2
    Old-Fogey:Addicts founder Terr's Avatar
    Join Date
    Aug 2001
    Seattle, WA
    I'm not sure exactly what happened to you, but I recently got my GF2 GTS 32mb working with Mandrake 8.1 without a hitch. Here's what I did. I got the .rpm's from NVIDIA, the GLX and the Kernel part (Make sure you download the 'nvchooser' executable script to tell which kernel version you need)

    So I used:


    And a copy of the readme file

    NVIDIA Accelerated Linux Driver Set README & Installation Guide

    Last Updated: $Date: 2001/11/26 $
    Most Recent Driver: 1.0-2313
    I opened the RPMs
    with the x-windows Package Manager. Installed them both.

    (I know this isn't quite that detailed, but I'm on Win98 right now)

    I opened up the sample X config file under /usr/share/doc/NVIDIA_GLX-1.0/ and compared it to what I had, basically merging the information at the correct places, in other words, editing my (real X-config file) entries for the card, and adding the module area in the same way that it was shown in the example.

    Then it was rebooting.

    I'll post more tomorrow, do you want a copy of my X config file or anything?

    (P.S.: I know it works, because I get a ton of frames per second in GLTron at high res)
    [HvC]Terr: L33T Technical Proficiency

  3. #3
    Computer Forensics
    Join Date
    Jul 2001
    Anthony: first off why the p in your tar ? tar -z(unzip)x(extract)v(verbose)f(file) the P is not necessary.

    secondly: after untarring, run ./configure to make sure you have the necessary things to install the package properly.

    thirdly: run the rpm with -Uvh next time

    fourth: run something like installing video drivers as root the first time.

    sounds like you did not test and ended up screwing up your XF86config file.

    I also take it this is redhat, you could try Xconfigurator to setup your video card.
    Antionline in a nutshell
    \"You\'re putting the fate of the world in the hands of a bunch of idiots I wouldn\'t trust with a potato gun\"

    Trust your Technolust

  4. #4
    AntiOnline Senior Member souleman's Avatar
    Join Date
    Oct 2001
    Flint, MI
    may have to do a make clean before the make install also.

    you can always get help in also...Since hogfly forgot to mention it
    \"Ignorance is bliss....
    but only for your enemy\"
    -- souleman

  5. #5
    Computer Forensics
    Join Date
    Jul 2001

    oh yeah come to and we can get it figured out for you...


    ra ra sis boom ba
    JP JP's irc ya!


    now that I am totally exhausted. latr
    Antionline in a nutshell
    \"You\'re putting the fate of the world in the hands of a bunch of idiots I wouldn\'t trust with a potato gun\"

    Trust your Technolust

  6. #6
    Senior Member linuxcomando's Avatar
    Join Date
    Sep 2001
    At first i thought Nvida really cool. It took a little while to get my geforce card working but i did.
    Then i started messing with Raedons graphics card and relized that all there drivers are Open Source so if i have a problem i can fix the driver myself!

  7. #7
    Did you check in your Xf86config-4 (not sure if it's the exact spelling) and made sure the driver you use is nvidia and not nv (Crappy non-3d driver included with most distros).
    Now these drivers are NOT perfect (sometimes when I switch from X to console it hangs my graphics and I need to reboot, so I try not to switch, and once in a while I saw X crash (I think 2 or 3 times since september)). Oh, my card is a Geforce2mx 400 64mb btw...

  8. #8
    Senior Member
    Join Date
    Nov 2001
    Yeah, your XF86config-4 ('etc/X11/XF86config-4' ) file is probably the problem- after installing the drivers you have to make a couple changes to the file.

    As Gepeto said- you have to change the line driver name from "nv" to "nvidia"
    Driver "nv"
    Driver "nvidia"

    Also make sure that the following lines are commented out or deleted
    • Load "dri"
    • Load "GLcore"

    That should get the driver working correctly

  9. #9
    Wickdgin: You seem to use a Geforce too...can you tell me what model, and tell me if it happened to you to have graphical crashes when switching from X to console back and forth? I have two friends (one with a TNT2 the other with an MX400 like mine) who have that problem too, and we are still looking for a fix..

  10. #10
    Senior Member
    Join Date
    Nov 2001
    I have a Nvidia GeForce 2 Go graphics card in my Dell Inspiron laptop running Redhat 7.2 & Win ME on a dual boot.

    The driver that was installed with Redhat never worked correctly and always would crash x-windows.

    I never had a problem with the Nvidia driver once I got my XF86config-4 file configured properly. If you are still having problems after you made those changes to your config file- then you probably need to change the values for your screen resolution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts