Results 1 to 5 of 5

Thread: window manager question with linux

  1. #1
    Blast From the Past
    Join Date
    Jan 2003

    window manager question with linux

    ok i have a book "running linux" by o'reilly books
    very good read and taught me $h1t loads of info
    but im still kinda clueless one something

    i downloaded icewm and fluxbox
    i want one of them to be my dominat manager as in when i type startx i want that to run
    im using rh9
    this book ses i have to modify my xinitrc script but the example looks nothing like what i have
    the following is my xiinitrc script

    # (c) 1999-2002 Red Hat, Inc.



    # merge in defaults
    if [ -f "$sysresources" ]; then
    xrdb -merge "$sysresources"

    if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"

    # merge in keymaps
    if [ -f "$sysxkbmap" ]; then
    setxkbmap `cat "$sysxkbmap"`

    if [ -f "$userxkbmap" ]; then
    setxkbmap `cat "$userxkbmap"`

    if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
    if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
    xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
    if [ -n "$xkbsymbols" ]; then
    setxkbmap -symbols "$xkbsymbols"

    # xkb and xmodmap don't play nice together
    if [ -z "$XKB_IN_USE" ]; then
    if [ -f "$sysmodmap" ]; then
    xmodmap "$sysmodmap"

    if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"

    unset XKB_IN_USE

    # run all system xinitrc shell scripts.
    for i in /etc/X11/xinit/xinitrc.d/* ; do
    if [ -x "$i" ]; then
    . "$i"

    # The user may have their own clients they want to run. If they don't,
    # fall back to system defaults.
    # set up ssh agent environment if available.

    if [ -f $HOME/.Xclients ]; then
    [ -x /usr/bin/ssh-agent -a -z "$SSH_AGENT_PID" ] && \
    exec ssh-agent $HOME/.Xclients || \
    exec $HOME/.Xclients
    elif [ -f /etc/X11/xinit/Xclients ]; then
    [ -x /usr/bin/ssh-agent -a -z "$SSH_AGENT_PID" ] && \
    exec ssh-agent /etc/X11/xinit/Xclients || \
    exec /etc/X11/xinit/Xclients
    # failsafe settings. Although we should never get here
    # (we provide fallbacks in Xclients as well) it can't hurt.
    xclock -geometry 100x100-5+5 &
    xterm -geometry 80x50-50+150 &
    if [ -x /usr/bin/netscape -a -f /usr/share/doc/HTML/index.html ]; then
    netscape /usr/share/doc/HTML/index.html &
    if [ -x /usr/X11R6/bin/fvwm2 ]; then
    exec fvwm2
    exec twm

    i dont care weather i use icewm or fluxbox but what ever u can help me with will be fine
    i chose the text login not graphical so i cant boot to fail safe and open icewm unless there really is a problem

    overall question

    want to use icewm OR fluxbox instead of kde or gnome
    dont no what to do to my xinitrc script cause it looks greek (for now)

    any sugestion/comment/etc... welcome
    thanx all
    work it harder, make it better, do it faster, makes us stronger

  2. #2
    I didnt understand if you intalled already icewm or not.

    Anyway, the INSTALL file that comes with icewm is pretty well documented and tell you evrything you need to start in X with it.

    From what I saw in your .xinitrc file the script looks first for fvwm2 and if it doest find it looks for twm to start it.

    In icewm INSTALL file you will find the requirements for running it and what to add to your .xinitrc file though and i quote "Normally, icewm should be started from ~/.Xclients file. This will work the same for 'startx' and 'xdm' logins. The file must have execute permissions (chmod a+x ~/.Xclients) ."

    But .xinitrc is a good file to start it up too.

    I suggest you read the INSTALL file and also the html doc that comes with icewm. Be sure you have XFreeype and a font comparable with Adobe's Helvetica.

    Good luck!

  3. #3
    Blast From the Past
    Join Date
    Jan 2003
    ok il look at the install docs and yes i have both of them icewm and fluxbox installed
    i did the same on a different box but if i wanted to use on of them i had to choose failsafe mode from the rh9 login menu then type blackbox or icewm or fluxbox or what ever i had installed
    work it harder, make it better, do it faster, makes us stronger

  4. #4
    Blast From the Past
    Join Date
    Jan 2003
    it worked
    i edited the ~.Xclients-default file to start icewm and open xterm and nautlius
    thanks for your help
    work it harder, make it better, do it faster, makes us stronger

  5. #5
    you're welcome!

    I guess the hard part will start now to configure icewm... I tried to set it on cygwin but eats way too much memory, blackbox wouldnt compile but openbox runs just smooth...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts