Results 1 to 9 of 9

Thread: W2k LAN Internet Connection Problem

  1. #1

    Question W2k LAN Internet Connection Problem

    Windows 2000 Server with Windows 2000 clients:

    I'm baffled at the moment and could really use some help. I'm having Internet connection problems on the LAN, but there's no pattern to it. Most of the computers connect just fine, but two of the computers, that have connected fine up until this point, have stopped connecting to the Internet. However, both computers are connected to the LAN okay and can access LAN resources without any problems; it's only the Internet these two computers cannot connect to.

    The way we're set up, we have a domain controller that handles Internet access for all clients. There's no hint of problems in its error logs.

    I've tried the following to troubleshoot:

    1) Through the command prompt, I've used ipconfig /release and ipconfig /renew (this used to fix the problem before).

    2) Rebooting computers

    3) Changing connection properties to both "detect DNS automatically" and manually using the domain controllers ip address.

    None of the above have resolved the problem. Keep in mind, all other computers are connecting with no problems, and these two were connecting -- no other strange activity has occured to give me any hints as to what the problem is.

    Can anyone throw me some ideas?

  2. #2
    AO Decepticon CXGJarrod's Avatar
    Join Date
    Jul 2002
    On the client machines:

    Have you tried manually putting in the DNS Server information? Just to see if somehow those two clients are getting the wrong DNS info.
    N00b> STFU i r teh 1337 (english: You must be mistaken, good sir or madam. I believe myself to be quite a good player. On an unrelated matter, I also apparently enjoy math.)

  3. #3
    Yeah, the inital setting was manual, to our DNS server: I then tried setting it to detect automatically (that sometimes does the trick), and that didn't work either, so I changed it back. Neither way seems to work.

    Whatever it is, it's only affecting these two machines and not the others for some reason. Very wierd.

  4. #4
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    Could it be some sort of software corruption on the client boxes?

    What actually should happen when they make an internet connection? do they just launch a browser and it does the rest?

    What actually does happen?


  5. #5
    What's supposed to happen is that either 1) the DNS is detected automatically or 2) it's set to (DNS server) if the prior doesn't work. Then, open Internet Explorer and everything's supposed to work fine. Instead, I get the "page cannot be displayed" for any website I try to go to.

    And the wierd thing is, other LAN resources are working okay. I can connect to terminal servers and shared folders, just not the Internet.

  6. #6
    This may be a clue...This appeared in the client machine's error log:

    The system failed to register network adapter with settings:
    Adapter Name : {.....}
    Host Name : JAMES
    Adapter-specific Domain Suffix : HIFS
    DNS server list :
    Sent update to server : None
    IP Address(es) :
    The cause of this DNS registration failure was because of DNS server failure. This may be due to a zone transfer that has locked the DNS server for the applicable zone that your computer needs to register itself with. (The applicable zone should typically correspond to the Adapter-specific Domain Suffix that was indicated above.) You can manually retry registration of the network adapter and its settings by typing "ipconfig /registerdns" at the command prompt. If problems still persist, contact your network systems administrator to verify network conditions.

    A similar error appeared on the other client:

    The system failed to register host (A) resource records (RRs) for network adapter
    with settings:

    Adapter Name : {7AC563DD-FBBC-4D0B-9388-9E62A01C5052}
    Host Name : BOBBY
    Primary Domain Suffix : HIFS
    DNS server list :,,
    Sent update to server : <?>
    IP Address(es) :

    The reason the system could not register these RRs was because the DNS server contacted refused the update request. The reasons for this might be (a) you are not allowed to update the specified DNS domain name, or (b) because the DNS server authoritative for this name does not support the DNS dynamic update protocol.

    To register the DNS host (A) resource records using the specific DNS domain name and IP addresses for this adapter, contact your DNS server or network systems administrator.

    (By the way, the latter machine is XP, but I doubt that has anything to do with the problem.)

    Then, on the domain controller, this error appeared:

    Source: LicenseService
    Category: None
    Event ID: 221

    License usage for product SMBServer 5.0 is nearing the maximum number of per server licenses purchased. Consult License Manager from the Administrative Tools folder for more information.

    All three errors occured during the same time frame, while I was trying to fix the problem. What's odd about the last error is that we don't even use SMBServer.

    I suspect this may be related, but I don't know what to make of it...

  7. #7
    AO Decepticon CXGJarrod's Avatar
    Join Date
    Jul 2002
    Ok. Two new things to try, but I am not sure if they will work.

    1) Try setting the DNS settings only to the internal DNS server. If it is pointed outside for its DNS, then shouldnt it get you to the net? If it does not work, then put it back the way it was before.

    2) Check out the licensing service on the 2k Server. See if all your licenses are used up. Start - Program - Administrative Tools - Licensing If they are, then buy some more or revoke some of the current ones to see if that helps. I had this happen on a 2k server where people could not login to one program because the licensing was full. Once I revoked some of the licenses that it was not using, it worked.

    Event only came up with the following for the Event ID 221:
    N00b> STFU i r teh 1337 (english: You must be mistaken, good sir or madam. I believe myself to be quite a good player. On an unrelated matter, I also apparently enjoy math.)

  8. #8
    Everything looks ok with licenses best I can tell, but what's strange is that SMBServer, the license in question, doesn't even appear.

    Also, I ran netdiag on one of the client machines, and it passed every test, except for this:

    DNS Test: Passed
    [WARNING] Cannot find a primary authoritative DNS server for the name "JAMES.HIFS.". [RCODE_SERVER_FAILURE]
    The name "JAMES.HIFS." may not be registered in DNS.

    That doesn't make any sense, because I know JAMES.HIFS (that's my machine, by the way), is listed in the Active Directory of the DNS as it should be.

  9. #9
    Got it! I had to cut the power to the router and replug it after a couple of minutes, then everything worked fine. It was THAT simple *slaps forehead*!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts