Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Software Installation Failure

  1. #1

    Question Software Installation Failure

    I'm stumped at the moment. The company I work for produces it's own in-house software that is sent out to clients. A few weeks ago, an employee called reporting that he had tried to reinstall his software after screwing up his previous software configuration, and it wouldn't work. While walking him through it on the phone, I couldn't get anywhere.

    Then, while trying to do the same thing on my computer (reinstall the software), I had the same problem! This is an coincidence because on the vast, vast majority of machines we use this software on, this problem never arises. In fact, this is the first time it's ever happened. It just so happens his and mine machines are the two trouble-makers by chance. Here's the details on the problems:

    1) Try to install the software over the previous installation. Installation fails.
    2) Removed previous software. Reinstallation fails.
    3) Further removed all folders for previous installation. Fresh installation still fails.

    In fact, the computer won't even try to install it. Autorun of the installation CD fails. When I go in to the CD drive folder and double-click setup, the green light on the drive lights up (it's at least reading), but nothing ever happens. Tried it from the command line, same thing.

    Of the countless machines this software is installed on, only these machines are exhibiting the problem. But I can click on setup.exe all day and nothing ever happens on these two.

    Any suggestions guys? OS is W2k.

  2. #2
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    Hi Angelic~

    Sorry, but I need to know, have both of you tried different installation CDs

    Also have you run a CD cleaner at least 3 times first?

    Just a thought

  3. #3
    Regal Making Handler
    Join Date
    Jun 2002
    It's probably down to the registry. Nokia had issues like this with some of there phone>>pc software, they had to produce another app for customers, who were having re-install problems. Basicaly what they had was a regcleaner to delete all traces of a previous install.

    Your problem souds very much like this. Having deleted all folders left behind after uninstalling go through the registry and delete all keys pertaining to the software. I would also delete all temp files created. If you have tried to re-install a few times you'll probably find loads

    What happens if a big asteroid hits the Earth? Judging from realistic simulations involving a sledge hammer and a common laboratory frog, we can assume it will be pretty bad. - Dave Barry

  4. #4
    Ok, I'm still getting used to using regedit, but haven't quite mastered it yet, so I may need a little detailed advising here. If I understand currently, I'm looking for entries for this software in

    HKEY_CURRENT_USER --> Software --> Folder for program
    HKEY_LOCAL_MACHINE --> Software --> Folder for program
    HKEY_CURRENT_CONFIG --> Software --> Folder for program

    Right? However, I haven't found any entries for it in any of those. Is there somewhere else I should be looking?

    Nihil, I tested to see if it was a CD issue, but the same CD works fine on other machines. Usually reinstallations go without a hitch, so our two machines are the first ones to ever have this problem. This is odd because all machines are W2k, so you wouldn't think it's an OS issue. And if it were something like a registry problem, I'd expect the problem to be consistent on all similar machines. So there's something on mine and his that's causing that problem that's not on everyone else's, one would think...

    It doesn't appear to be a CDROM issue either, as installation of any other software from CD works just fine on my machine.

  5. #5
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    Hi Angelic~

    Probably just me being stupid, but I have done internal software distros along the lines I think that you are talking about.

    I have had a CD that will load fine on a few machines, but not on another, yet a different CD did work on it.

    Maybe it has something to do with tolerances or whatever..............I would burn a couple of new CDs and try those?

    Just trying to eliminate the hardware element from the equation?


  6. #6
    Good idea, I'll give it a try and report back in a few...

    /edit -- Ok, gave it a try on another CD. Still didn't install. However, I did get a couple of messages this time, one of them from my new Registry Protector that I recently installed.

    /edit -- Tried two different copies of the CD. Same problem, won't install on mine but will reinstall on another machine.

  7. #7
    AO Decepticon CXGJarrod's Avatar
    Join Date
    Jul 2002
    Ok. I have seen a couple setups check the add/remove programs list before even installing to see if you have already installed the product. (Our program at work used to do this until we ran into some problems)

    You might try this:;en-us;243723

    and delete it from the add/remove programs menu. Then delete the entire folder (wherever the program installs), reboot and try a new installation.
    N00b> STFU i r teh 1337 (english: You must be mistaken, good sir or madam. I believe myself to be quite a good player. On an unrelated matter, I also apparently enjoy math.)

  8. #8
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington
    OK Angelic~

    1. What were the messages

    2. What is the Registry Protector

    I have to go out now, but will look back later. I hopefully will have a link to some registry cleaning software that I have used without problem for a few years.......maybe we can get it fixed that way?

    Incidentally, does you guy with the same problem also have the Registry Protector?

    In the meantime can you try a removal of all obvious files/folders (uninstall) then boot up and in task manager shut down everything you don't absolutely need for the box to work. Then try installing from the new CD.

    And do try a CD lens cleaner if you have one.........honest, it has worked for me......same symptoms some CDs would load others not, must be something to do with how close that data is packed.

    Another one to try, burn another CD at about 4-speed and give that a go............come across that problem before as well.

    Catch you later

  9. #9
    Jarrod -- Add/Remove programs entry and all program folders for it are long gone, that was one of the first things I did.

    Nihil -- Registry Proterctor is a neat litte secruity tool I downloaded recently. It pops up an alert window anytime anything tries to change a registry entry, so any software you use can't sneakily change an entry without you knowing about it and allowing it to.

    I saved the messages and tried to place the file in the last post so you could view them, evidently didn't work. Here's what they said:

    Registry Protector message:
    An important entry has been ADDED to the registry!
    DATA=grpconv -o

    Confirm File Replace:
    Source: C:\DOCUME~1\ADMINI~1.000\LOCALS~1\Temp\...\OLEAUT32.DLL
    Target: C:\WINNT\system32\OLEAUT32.DLL
    The target file exists and is newer than the source.

    And I'm the only one with Registry Protector, just something I installed to play with. As an aside, I really recommend it as a handy little security tool.

  10. #10
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington

    What answers did you give to the two messages?

    The second one is more interesting, as Windows should give you a similar warning that you are trying to update a newer file with an older one, and I am guessing that you don't get a message like that on the boxes where the installation works?

    You might check with your colleague to see if he gets a windows message like that?

    Please check the properties of the resident OLEAUT32.DLL files on your macine, your colleagues, and one of the machines where the upgrade modified etc.

    I am afraid it might be similar to a problem I had with MDAC versions. It looks as if you have installed something that has done a secret update of Windows components, and this is incompatible with your new installation.

    Just a thought

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts