Results 1 to 5 of 5

Thread: Vivarin - Redhat network 9 config

  1. #1
    Junior Member
    Join Date
    Jun 2004

    Redhat 9 network config

    I'm a total noob to linux.

    I have an HP EN1207D-TX PCI 10/100 Fast Ethernet Adapter that runs fine with winxp(of course).

    My system is a 600 mhz celeron running 256 mb.

    I have installed redhat 9 with kernal 2.4.20(thats what it says on the box).

    I've tried using network config to pick my card(or closest to it) on the list; none work.

    On the startup screen when redhat boots I see there too that any eth0, eth1 or whatever fail to intialize.

    I connect through dhcp.

    I've tried looking for drivers and haven't had much luck.

    Even if i got a driver that would work, I wouldn't know how to install it unless someone specifically instructed me.

    I have read some linux doc's and I have concluded it to be a driver issue.

    I have considered just buying a new network card off ebay or going to salvation army and pulling one from an old system but i would like to get mine to work if possible.

    Would It be possible to write a driver for this card or do you need exclusive information from HP?

    I Sincerely thank those that attemp to help me.

  2. #2
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003

    Vivarin - Redhat network 9 config

    I'm opening the thread here cause the other one got b0rked :

    Here's his demand :

    So to rewrite what i did answer before but what was lost :

    OK, If you're new to linux the most common problems are either network cards or soundproblems.

    First open a console (shell) :
    What do you see if you type "ifconfig" ? You should see ethx (where x is its number from 0 to ... )
    If you only see "lo" then probably you need to load a module or check the kernel.

    Anyway : Check this out, this covers your problem i think :

    Some more info here :

    Hereunder is what i found in a signature from a user :

    $ means as user # means as root if this is a shell command
    Gentoo, Pentium 3 1000 Mhz, 500 MB Ram, Geforce 4 Ti 4200 128MB DDR AGP 8x using Nvidia drivers, Sound Blaster PCI = Esoniq 5880 AudioPCI (es1371), HP EN1207D-TX PCI 10/100 Fast Ethernet Adapter = RealTek RTL-8139, SMC EZ Card
    So it seems it uses the realtek driver and/or chip , so :

    try this :

    #modprobe rtl8139
    #modprobe 8139too

    cause rtl8139 is the realltekdriver for older chips but still good, where 8139too seems a collection of support for different types of realtek chips. If you get a fatal error on the modprobe, then probably the driver needs to be compiled in the kernel.
    If it just returns to the commandline, most likely the modprobe loaded the driver, and need you to add thisdriver to autoload on next boot.
    Come and check out our wargame-site @
    We chat @ #lobby

  3. #3
    Junior Member
    Join Date
    Jun 2004
    ok, so what your saying is the Realtek RLT-8139 driver that ships with RH9 should work as an alernate for my card.

    I am in the graphical mode, btw. So I open up a "shell"<<does this appear as a choice on redhat's start button(for lack of me knowing the correct term)?

    After I open a "shell" type "ifconfig"
    then if I see "ethx(x=0-9)"
    then I type "#modprobe rtl8139" or "#modprobe 8139too"

    If I see "lo" does that mean I have to that mean I have to buy a new card or download something and load it from a disc?

  4. #4
    Junior Member
    Join Date
    Jun 2004
    i forgot to say i would like to get these instructions down for sure because i have to reformat my system to get redhat back on.

    oh, and if i have to load a "module" can this be downloaded in advance? or will i have to learn how to compile a driver? I've been playing around with Python a little, but how would i go about gettting info to write a driver?

  5. #5
    Junior Member
    Join Date
    Jun 2004
    ok i think i've loaded the drivers.
    after a little learning i managed to get root in shell and i entered the modprod commands you gave me and they did not show any fatal errors after being entered; they just went back to the command line.

    at the end of your instructions you said that i needed to add this driver to "autoboot" on next boot.
    How do i go about doing this?
    just to let other viewers of this thread that i would appriciate any help, not only .: Shrekkie :.'s

    thank you shrekkie and
    thanks to any one else willing to help!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts