I am in the early stages of a mythtv project and I want all sound to
pass through my SPDIF output into my surround sound amplifier.
(Obviously for 2 channel sound just the front L+R channels on my amp)

Using alsamixer I have turned on IEC958 output and have been able to
successfully use mplayer to send a surround signal vi SPDIF to my
mplayer -ao alsa -ac hwac3 dvd://

I though that the alsamixer switch :
Analog to IEC958 Output
was what I needed. However when I switch this on no sound is transferred
to the SPDIF and the above mplayer command produces no SPDIF sound
either. I believe the SPDIF is switched off at this point since the LED
indicating optical input on my amplifier goes out.

I also have a problem with mixer settings not being saved, but I think
with time I can figure that one out for myself, but I mention it in case
it's related.

I've tried getting my head around .asoundrc but when I think I know what
I'm doing, I end up with no sound out ot the SPDIF output at all and the
optical LED on the amplifier out. I've come to the conclusion that
the .asoundrc is beyond my intellectual skils

Any help appreciated.

[root@mythtv etc]# uname -a
Linux mythtv.lydgate.net 2.6.13-1.1532_FC4 #1 Thu Oct 20 01:30:08 EDT
2005 i686 i686 i386 GNU/Linux

[root@mythtv etc]# lspci | grep audio
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)

[root@mythtv etc]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.9b (Thu Jul 28
12:20:13 2005 UTC).

[root@mythtv etc]# cat /proc/asound/modules
0 snd_intel8x0

[root@mythtv etc]# cat /proc/asound/pcm
00-00: Intel ICH : Intel ICH5 : playback 1 : capture 1
00-01: Intel ICH - MIC ADC : Intel ICH5 - MIC ADC : capture 1
00-02: Intel ICH - MIC2 ADC : Intel ICH5 - MIC2 ADC : capture 1
00-03: Intel ICH - ADC2 : Intel ICH5 - ADC2 : capture 1
00-04: Intel ICH - IEC958 : Intel ICH5 - IEC958 : playback 1

[root@mythtv etc]# cat /proc/asound/cards
0 [ICH5 ]: ICH4 - Intel ICH5
Intel ICH5 with ALC650F at 0xfebff800, irq 7

[root@mythtv etc]# cat /proc/asound/card0/intel8x0

Global control : 0xc0000002
Global status : 0x00700100
SDM : 0x00000008
AC'97 codecs ready : primary
AC'97 codecs SDIN : 0 0 0

Note - I know there are some duplicate lines here (after I ran alsaconf)
but the problem existed before the last 5 lines were added.
[root@mythtv etc]# cat /etc/modprobe.conf
alias eth0 e100
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1
|| : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394
#alias char-major-195* nvidia
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.9a ---
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

Any more ?